Project

General

Profile

Actions

tickets #124793

closed

permission denied. Command output: Request was denied by your Redmine server.

Added by pjessen over 1 year ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Redmine
Target version:
-
Start date:
2023-02-20
Due date:
% Done:

0%

Estimated time:

Description

Permission denied. Command output: Request was denied by your Redmine server. 
Possible reasons: email is sent from an invalid email address or is missing some information.

I released a mail that had been held up by mailman, and it ended up getting rejected by redmine.
I'll see if I can maybe retrieve it from the archives and re-send. I wonder if there is a redmine logfile that will tell us more.


Related issues 1 (0 open1 closed)

Related to openSUSE admin - tickets #138290: anna/elsa - which smtp_bind_address to use?Resolvedcrameleon2023-10-19

Actions
Actions #1

Updated by pjessen over 1 year ago

  • Private changed from Yes to No

I'll see if I can maybe retrieve it from the archives and re-send.

Hmm, according to the settings, the list is being archived, but I don't see anything in hyperkitty. The archiver says "prototype" ??
Anyway, from memory, it was from "adam gretzinger at intel", about some mirror "suse.mobile-central.org" (not sure) going offline. If I am unable to recreate the mail, maybe I'll open a separate ticket.

The NDR created here was sent to admin-bounces, maybe that has been kept somewhere by mailman.

Actions #2

Updated by pjessen over 1 year ago

Just in case it matters - relay used was redmineprivate.

Actions #3

Updated by pjessen over 1 year ago

pjessen wrote:

Permission denied. Command output: Request was denied by your Redmine server. 
Possible reasons: email is sent from an invalid email address or is missing some information.

According to /opt/redmine/extra/mail_handler/rdm-mailhandler.rb, this is caused by a code 422 "Unprocessable Entity" from the redmine server. Since 4 January 2023, this has happened 172 times ... before that, 2388 times since 23 march 2022. Surely that is Not Good (R).

Actions #4

Updated by crameleon about 1 year ago

  • Category set to Redmine
Actions #5

Updated by crameleon 6 months ago

  • Status changed from New to Feedback
  • Assignee set to crameleon

Should no longer occur with the new Redmine, can you confirm?

Actions #6

Updated by pjessen 6 months ago

crameleon wrote in #note-5:

Should no longer occur with the new Redmine, can you confirm?

I don't see any such error messages any more - I think #138290 solved the problem.

Actions #7

Updated by pjessen 6 months ago

  • Related to tickets #138290: anna/elsa - which smtp_bind_address to use? added
Actions #8

Updated by crameleon 6 months ago

  • Status changed from Feedback to Resolved

There were a few more occurrences since after the MX migrations which I resolved now as well.

Actions

Also available in: Atom PDF