Project

General

Profile

Actions

action #123999

closed

[qe-core][functional]test fails in user_defined_snapshot

Added by rfan1 over 1 year ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2023-02-07
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP5-Online-x86_64-extra_tests_gnome@svirt-xen-hvm fails in
user_defined_snapshot

Test suite description

Maintainer: QE Core, asmorodskyi. Extra tests which were designed to run on gnome , VNC_STALL_THRESHOLD is needed for xen svirt to don't turn off the scrreen after default 4 sec

New version of extra_tests_on_gnome for yaml scheduling

Reproducible

Fails since (at least) Build 66.1

Expected result

Last good: 64.1 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by rfan1 over 1 year ago

  • Status changed from New to Feedback

Test passed with QEMURAM=2048 https://openqa.suse.de/tests/10441927#

I added this parameter in testsuite.

Actions #2

Updated by rfan1 over 1 year ago

  • Status changed from Feedback to In Progress

Increase the memory size didn't help much!

I will try to add some timeout for vm reset.

Actions #3

Updated by rfan1 over 1 year ago

Increase the timeout can't help as well, there might be some performance issue on xen setup and sometimes VMs hang there if we reboot in x11 mode.

So I will try to switch to the textmode to reboot the VM

http://openqa.suse.de/tests/overview?build=rfan_xen&version=15-SP5&distri=sle

Actions #5

Updated by rfan1 over 1 year ago

  • Status changed from In Progress to Feedback

PR is merged, let me wait for next openqa run result.

Actions #6

Updated by rfan1 over 1 year ago

  • Status changed from Feedback to In Progress

The test failed again in openQA run in next reset cycle.

Let me revert my PR and add the same workaround.

Actions #7

Updated by rfan1 over 1 year ago

  • Status changed from In Progress to Feedback

RETRY=2:poo#123999

Seems there are some performance issue on xen host to run many tests at the same time.
Let me try to add a re-try logic and see.

Actions #8

Updated by rfan1 over 1 year ago

  • Status changed from Feedback to In Progress

Add retry can't help :(

Actions #9

Updated by rfan1 over 1 year ago

I will try to un-schedule this test on xen, this issue is sporadic one and VM gets stuck with unknown reason during reboot. I can't catch up any usual logs in serial console and xen host.

Next action item can be:

  1. upgrade the xen host to newer SLE version (it is sles15sp2 right now)
  2. find a new xen host to see if the issue is caused by performce.
  3. file a bug if we can find some usual logs
Actions #10

Updated by rfan1 over 1 year ago

  • Status changed from In Progress to Blocked

https://bugzilla.suse.com/show_bug.cgi?id=1208663

I filed a new bug and hopefully the serial logs can help.

Actions #11

Updated by slo-gin 2 months ago

This ticket was set to Normal priority but was not updated within the SLO period. Please consider picking up this ticket or just set the ticket to the next lower priority.

Actions #12

Updated by rfan1 about 2 months ago

  • Status changed from Blocked to Closed

The issue is gone on sle15sp6, let me close it for now

Actions

Also available in: Atom PDF