Project

General

Profile

action #12064

Improved logging for debugging performance related issues

Added by okurz almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
-
Start date:
2016-05-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

User story

As a developer trying to fix sporadic or potential performance issues, I want access to more logs and data from the SUT to be able to distinguish "openQA worker" performance impact from performance regressions in the product

acceptance criteria

  • Logfiles with blocked tasks and system load is available in case of sporadic failures

tasks

  • Call "uptime" in case of error which gives information about load, too, e.g. 13:57 up 16 days 1:09, 0 users, load average: 0.25, 0.42, 0.48 or call cat /proc/loadavg
  • Optional: Repeatedly call the above over some time, e.g. before and after every test

further details

related to #11928


Related issues

Related to openQA Tests - action #12110: gnome_control_center: short timeout on details caused test to failResolved2016-05-24

Related to openQA Project - coordination #14972: [tools][epic] Improvements on backend to improve better handling of stallsResolved2016-11-24

History

#1 Updated by okurz almost 6 years ago

  • Related to action #12110: gnome_control_center: short timeout on details caused test to fail added

#2 Updated by okurz almost 6 years ago

  • Assignee set to okurz

#3 Updated by okurz almost 6 years ago

PR ready: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/1393

the "psaxf" should be enough to see if any processes are blocked or is more necessary?

#4 Updated by okurz almost 6 years ago

  • Status changed from New to In Progress

#5 Updated by okurz almost 6 years ago

  • Status changed from In Progress to Feedback
  • Assignee deleted (okurz)

PR is merged, let's see if anything else comes up.

#6 Updated by okurz over 5 years ago

  • Status changed from Feedback to Resolved
  • Assignee set to okurz

we improved a lot in this regard since the last comment. coolo added performance checks for check/assert_screen call durations and also some others. Tests abort when there is a timeout on check/assert_screen and previously delays have been encountered. Also, IO related logs are available in the logfiles.

#7 Updated by okurz over 5 years ago

  • Related to coordination #14972: [tools][epic] Improvements on backend to improve better handling of stalls added

Also available in: Atom PDF