Project

General

Profile

action #120366

Rewrite regression job group configuration by breaking borrowed settings from old testsuites

Added by zoecao 3 months ago. Updated about 20 hours ago.

Status:
Resolved
Priority:
Low
Assignee:
Target version:
Start date:
2022-11-14
Due date:
% Done:

0%

Estimated time:

Description

Observation

In migration regression group, the cases settings are mixed from job yaml and test suites, such as:

- online_sles15sp2_ltss_pscc_basesys-srv-desk-dev-contm-lgm-py2-tsm-wsm-pcm_all_full:
         **testsuite: online_sles15sp1_pscc_Addons-basesys-srv-desk-dev-contm-lgm-pcm-py2-tsm-wsm_all_full**
         settings:
            SCC_ADDONS: base,serverapp,desktop,dev,contm,lgm,python2,tsm,wsm,ltss,pcm
            ...

testsuite online_sles15sp1_pscc_Addons-basesys-srv-desk-dev-contm-lgm-pcm-py2-tsm-wsm_all_full is created in https://openqa.suse.de/admin/test_suites
So the case borrowed some settings from old testsuites, need to break it. Expecting two HPC cases, all the SLES cases settings need to break borrowing settings.

Acceptance criteria

AC1: rewrite the case settings for regression group cases (sles only), break borrowing settings from old test suites, and add the required settings in job template yaml file.

History

#1 Updated by JERiveraMoya 3 months ago

  • Subject changed from Rewrite the regression group cases: break borrowing settings from old testsuites to Rewrite regression job group configuration by breaking borrowed settings from old testsuites
  • Description updated (diff)
  • Priority changed from Normal to Low

#2 Updated by JERiveraMoya 3 months ago

zoecao I could not find that test suite in openQA web, it is due to that problem of visualization? if so, worth to mention on the ticket as linked issue, wdyt?

#3 Updated by zoecao 2 months ago

JERiveraMoya wrote:

zoecao I could not find that test suite in openQA web, it is due to that problem of visualization? if so, worth to mention on the ticket as linked issue, wdyt?

The old test suites can not be shown on openQA web, see https://progress.opensuse.org/issues/120315 & https://openqa.suse.de/api/v1/test_suites?limit=5000

#4 Updated by JERiveraMoya about 2 months ago

  • Tags deleted (qe-yam-refinement)
  • Status changed from New to Workable

#5 Updated by hjluo about 2 months ago

  • Status changed from Workable to In Progress
  • Assignee set to hjluo

#8 Updated by hjluo about 20 hours ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF