Project

General

Profile

action #119179

[openQA][iso] Fail to mount nfs share openqa.suse.de:/var/lib/openqa/share/factory/iso/fixed

Added by waynechen55 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
Start date:
2022-10-21
Due date:
% Done:

0%

Estimated time:

Description

Observation

The latest openQA test run failed because nfs share mount failed,so test can not proceed to load iso media in it:
Here is the failure screenshot and text info.
The last good example is here

Steps to reproduce

  • Run test gi-guest_oraclelinux-on-host_developing-kvm
  • Wait it to mount iso media folder openqa.suse.de:/var/lib/openqa/share/factory/iso/fixed or
  • Try to mount manually on a test machine

Impact

Test gi-guest_oraclelinux-on-host_developing-kvm can not pass because there is no way for it to access iso media.

Problem

I am not granted any privilege on openqa.suse.de, so I can not do any investigation.
I guest there is something wrong with nfs configuration.

Suggestion

  • Check nfs share config for openqa.suse.de:/var/lib/openqa/share/factory/iso/fixed
  • Check nfs share mounting a client machine to test connectivity

Workaround

n/a

History

#1 Updated by okurz 4 months ago

  • Due date set to 2022-11-06
  • Status changed from New to Feedback
  • Assignee set to okurz
  • Target version set to Ready

Tests should not rely on NFS shares but only access assets locally which are provided by the openQA worker cache. Please change the tests to not rely on the NFS shares

#2 Updated by waynechen55 4 months ago

  • Assignee deleted (okurz)
  • Target version deleted (Ready)

okurz wrote:

Tests should not rely on NFS shares but only access assets locally which are provided by the openQA worker cache. Please change the tests to not rely on the NFS shares

Could you help tell how to access assets from openQA worker cache ? If the original copy is located in /var/lib/openqa/share/factory/iso/fixed ? An example is the best.

#3 Updated by okurz 4 months ago

  • Assignee set to okurz
  • Target version set to Ready

waynechen55 Just specify the asset by name and assure it's being mentioned in the openQA settings of the according jobs, e.g. within the ISO variable

#4 Updated by okurz 3 months ago

  • Due date deleted (2022-11-06)
  • Status changed from Feedback to Resolved

resolving with "no response"

Also available in: Atom PDF