Project

General

Profile

Actions

tickets #118057

closed

tickets #117442: [Regression] Regression test for SLED

tickets #117895: [Regression][RemoteLogin] Remote Login components of regression tests

[Regression][RemoteLogin] Remote Login: One-time VNC Session failed due to a previous graphical session

Added by zcjia over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
already_automated
Target version:
Start date:
2022-10-12
Due date:
% Done:

0%

Estimated time:
Relevance:
P3

Description

Description:
SLED using tigervnc access a SLES which is already using a desktop and the multiple login is detected by gdm and refused

Setup:
Client: SLED15
Server: SLES12SP3 with xvnc enabled but without session management
    - run as root user: yast2 remote
    - Click "Allow Remote Administration Without Sessions
Management"
    - Check "Open Port in Firewall"
    - Click "OK"
    - Press "Alt-f2" then input "r" to restart gdm
    - You have to log in the graphical session before the remote access

Steps:
    Note: You have to log in the graphical session in SLES before the remote access

  1. Launch gnome-terminal in SLED as normal user then input "vncviewer"
  2. Enter the host(eg: IP:1) into the VNC server field and click "Connect"
  3. There will be a popup window named "hostname mismatch" if your connection does not use TLS, then click "Yes"
  4. Input the password and log in the system
  5. Close vncviewer

  6. vncviewer can be launched successfully

  7. It starts a graphical login screen

  8. Log in failed with notification:
        Sorry, You have to log out a previous session first, Multiple logins are not supported.


Related issues 1 (0 open1 closed)

Copied to QE-Workstation - tickets #150566: [Regression][RemoteLogin] Remote Login: One-time VNC Session failed due to a previous graphical sessionResolvedGraceWang2022-10-12

Actions
Actions #1

Updated by GraceWang over 1 year ago

  • Assignee set to zcjia
Actions #2

Updated by zcjia over 1 year ago

  • Status changed from New to Resolved
  • Relevance changed from P5 to P3

Tested in build 64.1.

Actions #3

Updated by zcjia 7 months ago

  • Copied to tickets #150566: [Regression][RemoteLogin] Remote Login: One-time VNC Session failed due to a previous graphical session added
Actions

Also available in: Atom PDF