Project

General

Profile

action #115229

[Timebox: 24h] Review PRD regarding Upgrade/Migration to SLE-15-SP5

Added by JERiveraMoya about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2022-08-11
Due date:
% Done:

0%

Estimated time:

Description

Motivation

Review new RPD and define new test cases for SLE-15-SP5 test cases.
For HPC test cases, we normally need to communicate with HPC project manager in order to confirm migration path and other details.

Acceptance criteria

AC1: List test coverage changes
AC2: List test coverage changes once confirmed with project manager of additional products (HPC,...)
AC3: Demo for the squad about those changes

Suggestions

With listing the changes in a comprehensible way is enough, no need for creating new tickets for now, we can do it after demo.


Related issues

Related to qe-yast - coordination #115322: [Epic] Update test coverage based on PRD for migration paths in SLE 15 SP5Workable2022-08-15

History

#1 Updated by JERiveraMoya about 2 months ago

  • Status changed from New to Workable

#2 Updated by zoecao about 2 months ago

  • Status changed from Workable to In Progress

#3 Updated by zoecao about 2 months ago

I have read the prd, checked the products lifecycle and the modules available on SLES15SP4, conclusions as below:
For SLES migration path:
From sles12sp3 (TBD), sles12sp4, sles12sp5, sles15sp2, sles15sp3, sles15sp4 to sles15sp5

  • So comparing with the current cases in migration groups, the test coverage changes are the to be added sles15sp4 migration path and the to be removed SLES15SP1 migration path (and might need to remove sles12sp3 migration path which is still TBD) PS: on the ha migration confluence page, the migration path of sles15sp1 is listed, need to confirm it with PM, because on prd, it states that migration from SLE15SPx to SLE15SPx+3 is supported, from SLE15SPx to SLE15SPx+4 is NOT supported.
  • For the new cases of sles15sp4 -> sles15sp5, python3 module is a new module that available since sle15sp4, need to add it for migration testing.

For SLED migration path:
From sled15sp4

For HPC migration path:
From sle-hpc-15sp4
I'll create migration matrix (add the cases of SLE15SP4) next Monday and send to team.

#4 Updated by zoecao about 1 month ago

I created the draft of sle15sp5 migration matrix, and shared it with team via sharepoint for review.
BTW, the work flow of making migration matrix is:

  1. reading PRD to confirm the supported migration path
  2. create cases in migration matrix
  3. send the matrix to team for review
  4. then send to PM to review the matrix (because the matrix is based on PRD, while sometimes the PRD might have errors or just a draft at the early phase of a under developing product)
  5. modify matrix if any feedback from PM
  6. when no problems with the matrix, deploy the cases to openQA

#5 Updated by JERiveraMoya about 1 month ago

  • Subject changed from [Research: 24h] Review PRD regarding Upgrade/Migration to SLE-15-SP5 to [Timebox: 24h] Review PRD regarding Upgrade/Migration to SLE-15-SP5

#6 Updated by JERiveraMoya about 1 month ago

  • Related to coordination #115322: [Epic] Update test coverage based on PRD for migration paths in SLE 15 SP5 added

#7 Updated by JERiveraMoya about 1 month ago

  • Tags deleted (qe-yast-refinement)
  • Status changed from In Progress to Workable

#8 Updated by JERiveraMoya about 1 month ago

  • Status changed from Workable to In Progress

#9 Updated by JERiveraMoya about 1 month ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF