Project

General

Profile

action #115226

Use ext4 (instead of ext2) for /var/lib/openqa on qa-power8 workers

Added by mkittler about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2022-08-11
Due date:
% Done:

0%

Estimated time:

Description

Those two workers use ext2 as file system for the partition /var/lib/openqa is mounted on which has no journaling and is therefore quite error prone (see #114565#note-35). It would make sense to re-format the related partition to use ext4 instead because those workers don't run the service to re-create the file system on boot (and therefore the file system is persistent).

Acceptance criteria

  • AC1: qa-power8-4 and *-5 use a journaling-enabled file system for /var/lib/openqa (e.g. ext4)

Further notes

  • powerqaworker-qam-1 is not affected because it has no extra mount for /var/lib/openqa (so the data is just stored on the root file system using btrfs)

History

#1 Updated by okurz about 2 months ago

  • Target version set to Ready

#2 Updated by mkittler about 2 months ago

  • Assignee set to mkittler

#3 Updated by okurz about 2 months ago

  • Description updated (diff)

I paused the alert "Failed systemd services alert (except openqa.suse.de)" due to related alerts and added a rollback step to the description

#4 Updated by mkittler about 2 months ago

  • Description updated (diff)
  • Status changed from New to Feedback
  • Assignee deleted (mkittler)
  • Target version deleted (Ready)

The only failed service that's currently left is on grenache-1 which I haven't touched. (The other failing services were caused by my work but that should now be resolved.)

I re-created the filesystem on both hosts and made necessary adjustments and rebooted them to see whether it is correctly mounted on startup. It all looks good so far.

#5 Updated by mkittler about 2 months ago

  • Assignee set to mkittler
  • Target version set to Ready

#6 Updated by mkittler about 1 month ago

  • Status changed from Feedback to Resolved

Both workers are still running without further alerts so I guess we're good.

Also available in: Atom PDF