Project

General

Profile

action #114959

[qem][qe-core]test fails in logs_from_installation_system, "wait_countdown_stop" function can't stop auto reboot process

Added by rfan1 about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-08-04
Due date:
% Done:

100%

Estimated time:
2.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP5-Server-DVD-Updates-aarch64-qam-minimal+base@aarch64-virtio fails in
logs_from_installation_system

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml.

Reproducible

Fails since (at least) Build 20220803-1

Expected result

Last good: 20220802-1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #113396: [qe-core]test fails in logs_from_installation_system due to 'wait_countdown_stop' function doesn't work fine, performance issue?Resolved2022-07-08

Related to openQA Tests - action #115079: [qe-core][qem&functional] Many test failures due to low performance on arm workersNew2022-08-08

History

#1 Updated by rfan1 about 2 months ago

  • Related to action #113396: [qe-core]test fails in logs_from_installation_system due to 'wait_countdown_stop' function doesn't work fine, performance issue? added

#2 Updated by rfan1 about 2 months ago

  • Subject changed from [qem][qe-core]test fails in logs_from_installation_system to [qem][qe-core]test fails in logs_from_installation_system, "wait_countdown_stop" function can't stop auto reboot process

SLE15SP1 can hit the issue as well
https://openqa.suse.de/tests/9264526#

#3 Updated by mgrifalconi about 2 months ago

  • Priority changed from Normal to High

Raising prio since it's a sporadic (but very frequent) issue that requires lots of restarts

#4 Updated by rfan1 about 2 months ago

The workaround used for SLE15 before [mentioned at https://progress.opensuse.org/issues/113396] can work for SLE15SP1/SLE12SP5 as well

# openqa-clone-job  --from http://openqa.suse.de --host http://openqa.suse.de  9264526  _GROUP_ID=0 -skip-download --skip-chained-deps BUILD=rfan1_test TEST=rfan-qam-minimal+base REBOOT_TIMEOUT=0 EXCLUDE_MODULES=logs_from_installation_system,reboot_after_installation
Created job #9264843: sle-15-SP1-Server-DVD-Updates-aarch64-Build20220804-1-qam-minimal+base@aarch64-virtio -> http://openqa.suse.de/t9264843
# openqa-clone-job  --from http://openqa.suse.de --host http://openqa.suse.de  9263460  _GROUP_ID=0 -skip-download --skip-chained-deps BUILD=rfan1_test TEST=rfan-qam-minimal+base REBOOT_TIMEOUT=0 EXCLUDE_MODULES=logs_from_installation_system,reboot_after_installation
Created job #9265473: sle-12-SP5-Server-DVD-Updates-aarch64-Build20220804-1-qam-minimal+base@aarch64-virtio -> http://openqa.suse.de/t9265473

#5 Updated by rfan1 about 2 months ago

  • Assignee set to rfan1
  • Target version set to QE-Core: Ready
  • Estimated time set to 2.00 h

#6 Updated by rfan1 about 2 months ago

  • Related to action #115079: [qe-core][qem&functional] Many test failures due to low performance on arm workers added

#7 Updated by rfan1 about 2 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 60

#8 Updated by rfan1 about 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

Test passed on both 15sp1 and 12sp5

Also available in: Atom PDF