Project

General

Profile

Actions

action #112250

closed

action #109707: [qe-core] Detect when a maintenance update has been already released before running the test

[QE-Core] zypper modify repo incorrect usage is muted in the patch_and_reboot test

Added by dvenkatachala over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-06-09
Due date:
% Done:

0%

Estimated time:
Difficulty:
Sprint:
QE-Core: June Sprint (Jun 08 - Jul 06)

Description

Observation

In serial terminal of the job https://openqa.suse.de/tests/8918499, we can see usage message like this:

Alias or an aggregate option is required.
modifyrepo (mr) <OPTIONS> <ALIAS|#|URI>
modifyrepo (mr) <OPTIONS> <--all|--remote|--local|--medium-type>

Modify properties of repositories specified by alias, number, or URI, or by the '--all, --remote,
--local, --medium-type' aggregate options.

  Command options:

-n, --name <NAME>           Set a descriptive name for the repository.
-e, --enable                Enable a disabled repository. Default: true
-d, --disable               Disable the repository (but don't remove it).
-f, --refresh               Enable auto-refresh of the repository. Default: false
-F, --no-refresh            Disable auto-refresh of the repository.
-p, --priority <PRIORITY>   Set priority of the repository. Default: 0
-k, --keep-packages         Enable RPM files caching. Default: false
-K, --no-keep-packages      Disable RPM files caching.
-g, --gpgcheck              Enable GPG check for this repository.
    --gpgcheck-strict       Enable strict GPG check for this repository.
    --gpgcheck-allow-unsigned
                            Short hand for '--gpgcheck-allow-unsigned-repo
                            --gpgcheck-allow-unsigned-package'.
    --gpgcheck-allow-unsigned-repo
                            Enable GPG check but allow the repository metadata to be unsigned.
    --gpgcheck-allow-unsigned-package
                            Enable GPG check but allow installing unsigned packages from this
                            repository.
-G, --no-gpgcheck           Disable GPG check for this repository.
    --default-gpgcheck      Use the global GPG check setting defined in /etc/zypp/zypp.conf. This is
                            the default.
-a, --all                   Apply changes to all repositories. Default: false
-l, --local                 Apply changes to all local repositories. Default: false
-t, --remote                Apply changes to all remote repositories. Default: false
-m, --medium-type <TYPE>    Apply changes to repositories of specified type.

  Legacy options:

-r                          The same as -f.
-R                          The same as -F.`

But there is no failures related to this. Looks like we have similar issue with other architecture.

openQA test in scenario sle-15-SP2-Server-DVD-Updates-x86_64-Build20220608-1-mru-install-desktop-with-addons@64bit fails in
patch_and_reboot

Test suite description

Reproducible

Fails since (at least) Build 20220530-1 (current job)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by dvenkatachala over 1 year ago

  • Tags deleted (june-sprint)
Actions #2

Updated by szarate over 1 year ago

  • Sprint set to QE-Core: June Sprint (Jun 08 - Jul 06)
  • Tags set to june-sprint
  • Target version set to QE-Core: Ready
Actions #3

Updated by dvenkatachala over 1 year ago

  • Subject changed from [QE-Core] zypper incorrect usage is muted in the patch_and_reboot test to [QE-Core] zypper modify repo incorrect usage is muted in the patch_and_reboot test
Actions #4

Updated by dvenkatachala over 1 year ago

  • Status changed from Workable to Feedback

I sincerely apologize for creating this ticket. There is no issue in the test. In the test, command zypper modifyrepo(mr) is trying to disable the repository.
Command execution displays the incorrect usage if the repository does not exist and it is handled in the test by exit code 3.

Actions #5

Updated by dvenkatachala over 1 year ago

  • Status changed from Feedback to Rejected
Actions

Also available in: Atom PDF