Project

General

Profile

action #112130

os-autoinst tests fail due to unexpected warning with perl 5.36

Added by AdamWill 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-06-07
Due date:
2022-06-22
% Done:

0%

Estimated time:
Difficulty:

Description

Trying to run the os-autoinst test suite with perl 5.36 results in a failure due to an unexpected warning:

2: ok 1697 ms ( 0.02 usr 0.00 sys + 1.46 cusr 0.33 csys = 1.81 CPU)
2: Implicit use of @_ in goto with signatured subroutine is experimental at /builddir/build/BUILD/os-autoinst-ab6013d738344791507525e45cbd9f972a444968/backend/console_proxy.pm line 59.
2:
2: # Failed test 'no (unexpected) warnings (via done_testing)'
2: # at ./03-testapi.t line 873.
2: # Got the following unexpected warnings:
2: # 1: Implicit use of @_ in goto with signatured subroutine is experimental at /builddir/build/BUILD/os-autoinst-ab6013d738344791507525e45cbd9f972a444968/backend/console_proxy.pm line 59.
2: # Looks like you failed 1 test of 42.
2: [21:44:58] ./03-testapi.t ...........................

Our perl maintainer writes:

"The failure is caused by new warnings[1]:

Implicit use of @_ in %s with signatured subroutine is experimental

An expression that implicitly involves the @_ arguments array was found in a subroutine that uses a signature

[1]https://metacpan.org/dist/perl/view/pod/perldelta.pod#New-Warnings"

History

#1 Updated by tinita 2 months ago

  • Status changed from New to In Progress
  • Assignee set to AdamWill
  • Target version set to Ready

Chatted with Adam in our matrix channel. The culprit is very likely the goto &$AUTOLOAD https://github.com/os-autoinst/os-autoinst/blob/master/backend/console_proxy.pm#L55 which implicitly uses @_.
Adam is working on a fix.

#2 Updated by AdamWill 2 months ago

https://github.com/os-autoinst/os-autoinst/pull/2075 should fix this plus a bunch of others that showed up after this was fixed. Thanks to tinita for all the guidance.

#3 Updated by openqa_review 2 months ago

  • Due date set to 2022-06-22

Setting due date based on mean cycle time of SUSE QE Tools

#4 Updated by tinita 2 months ago

  • Status changed from In Progress to Resolved

Thanks Adam!

Also available in: Atom PDF