Project

General

Profile

action #107623

Investigate which update causes rootless_podman regression in 15-SP3.

Added by jlausuch 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-02-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Since 24 Feb, one of the updates in BASE_TEST_ISSUES is causing a regression in rootless podman.

It only happens in 15-SP3 Update jobs.
BASE_TEST_ISSUES=21897,22201,22540,22559,22637,22670,22688,22700,22721,22726,22748,22752,22756,22834,22837,22848,22857,22863,22881,22884,22909,22914,22921,22926,22933,22948,22951,22955,22961,22965,22970,22971,22973,22977,22990

podman version: 2.1.1

I have started doing some small investigation and neither https://smelt.suse.de/incident/22201/ or https://smelt.suse.de/incident/22843/ (buildah update) cause the issue.

openQA test in scenario sle-15-SP3-JeOS-for-kvm-and-xen-Updates-x86_64-jeos-containers@64bit-virtio-vga fails in
rootless_podman

Test suite description

Reproducible

Fails since (at least) Build 20220224-1

Expected result

Last good: 20220223-1 (or more recent)

Further details

Always latest result in this scenario: latest

rootless podman.png (56.9 KB) rootless podman.png jlausuch, 2022-02-25 08:09
12904

History

#1 Updated by jlausuch 4 months ago

  • Status changed from Workable to In Progress
  • Assignee set to jlausuch

The affected job is not only JeOS. Of course, this also happens in Server: https://openqa.suse.de/tests/8227039#step/rootless_podman/105

#2 Updated by jlausuch 4 months ago

I found the incident that causes this regression.
Proof: http://fromm.arch.suse.de/tests/5744#settings with BASE_TEST_ISSUES=22990

I have executed the exact same test with all the other incidents IDs except this one and it ok, but installing this update makes the test fail with the error in the description.

Smelt: https://smelt.suse.de/incident/22990/
IBS request: https://build.suse.de/request/show/264108 (libseccomp)

#3 Updated by jlausuch 4 months ago

  • Status changed from In Progress to Resolved

Already notified maintenance team.

Also available in: Atom PDF