Project

General

Profile

action #106035

[qe-tools] dehydrated service fails on osd

Added by osukup 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
Start date:
2022-02-07
Due date:
% Done:

0%

Estimated time:

Description

OSD has systemd in degraded state because system service dehydrated ends in failed state ..

dehydrated.service - Certificate Update Runner for Dehydrated
     Loaded: loaded (/usr/lib/systemd/system/dehydrated.service; static)
     Active: failed (Result: exit-code) since Mon 2022-02-07 09:03:35 CET; 4min 58s ago
TriggeredBy: ‚óŹ dehydrated.timer
    Process: 26947 ExecStart=/usr/bin/dehydrated --cron (code=exited, status=1/FAILURE)
   Main PID: 26947 (code=exited, status=1/FAILURE)

Feb 07 09:03:34 openqa systemd[1]: Starting Certificate Update Runner for Dehydrated...
Feb 07 09:03:34 openqa dehydrated[26947]: # INFO: Using main config file /etc/dehydrated/config
Feb 07 09:03:34 openqa dehydrated[26947]: # INFO: Using additional config file /etc/dehydrated/config.d/suse-ca.sh
Feb 07 09:03:34 openqa dehydrated[26947]: # INFO: Running /usr/bin/dehydrated as dehydrated/dehydrated
Feb 07 09:03:34 openqa sudo[26947]:     root : PWD=/ ; USER=dehydrated ; GROUP=dehydrated ; COMMAND=/usr/bin/dehydrated --cron
Feb 07 09:03:35 openqa dehydrated[27267]: {}
Feb 07 09:03:35 openqa systemd[1]: dehydrated.service: Main process exited, code=exited, status=1/FAILURE
Feb 07 09:03:35 openqa systemd[1]: dehydrated.service: Failed with result 'exit-code'.
Feb 07 09:03:35 openqa systemd[1]: Failed to start Certificate Update Runner for Dehydrated.

Related issues

Is duplicate of openQA Infrastructure - action #105960: Dehydrated fails on OSD size:MResolved2022-02-04

History

#1 Updated by osukup 5 months ago

# /usr/bin/dehydrated -c
# INFO: Using main config file /etc/dehydrated/config
# INFO: Using additional config file /etc/dehydrated/config.d/suse-ca.sh
# INFO: Running /usr/bin/dehydrated as dehydrated/dehydrated
# INFO: Using main config file /etc/dehydrated/config
# INFO: Using additional config file /etc/dehydrated/config.d/suse-ca.sh
Processing openqa.suse.de with alternative names: openqa.nue.suse.com
 + Checking domain name(s) of existing cert... unchanged.
 + Checking expire date of existing cert...
 + Valid till Feb 26 23:09:44 2022 GMT (Less than 23 days). Renewing!
 + Signing domains...
 + Generating signing request...
 + Requesting new certificate order from CA...
  + ERROR: An error occurred while sending post-request to https://ca-internal.suse.de/acme/acme/new-order (Status 500)

Details:
HTTP/2 500 
cache-control: no-store
content-type: application/json
link: <https://ca-internal.suse.de/acme/acme/directory>;rel="index"
replay-nonce: cVBka0ZQSWszelFSNkc4akEyVjB2YVRhNUFtNHlFb3g
content-length: 3
date: Mon, 07 Feb 2022 08:24:27 GMT

{}


/usr/bin/dehydrated: line 737: 1: unbound variable

#2 Updated by okurz 5 months ago

  • Is duplicate of action #105960: Dehydrated fails on OSD size:M added

#3 Updated by okurz 5 months ago

  • Status changed from New to Rejected
  • Assignee set to okurz
  • Target version set to Ready

see #105960

Also available in: Atom PDF