Project

General

Profile

action #105148

[qe-core] test fails in openssl_nodejs

Added by mgrifalconi 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-01-20
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP5-Server-DVD-Updates-x86_64-mau-extratests1@64bit fails in
openssl_nodejs

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Run console tests against aggregated test repo

Reproducible

Fails since (at least) Build 20220120-1 (current job)

Expected result

Last good: 20220119-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by mgrifalconi 4 months ago

Solution from Adam:

For the FIPS test test/parallel/test-crypto-fips.js, it's failing because there is a missing libopenssl1_1-hmac package so FIPS cannot be enabled. 

For the first first test, it requires building of ./test/fixtures/test_crypto_engine.c which means that test/parallel/test-crypto-engine.js should probably be skipped.

Creating a PR to skip the first test and install the missing package

#3 Updated by mgrifalconi 4 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF