Project

General

Profile

action #105103

[sle][migration][sle15sp4][Regression]test fails in check_system_info - zypper lr timeout

Added by coolgw 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-01-20
Due date:
% Done:

0%

Estimated time:
10.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP4-Regression-on-Migration-from-SLE12-SPx-s390x-offline_sles12sp4_ltss_media_sdk-asmm-contm-lgm-tcm-wsm_all_full@s390x-kvm-sle12 fails in
check_system_info

Test suite description

Base following correct case you will took 31seconds to execute zypper lr, so we need enlarge this command.
[2022-01-17T07:45:51.002349+01:00] [debug] ||| starting check_system_info tests/console/check_system_info.pm
[2022-01-17T07:45:51.023072+01:00] [debug] tests/console/check_system_info.pm:86 called testapi::select_console
[2022-01-17T07:45:51.023192+01:00] [debug] <<< testapi::select_console(testapi_console="root-console")
[2022-01-17T07:45:51.029340+01:00] [debug] tests/console/check_system_info.pm:86 called testapi::select_console -> lib/susedistribution.pm:893 called testapi::assert_screen
[2022-01-17T07:45:51.029449+01:00] [debug] <<< testapi::assert_screen(mustmatch="root-console", no_wait=1, timeout=30)
[2022-01-17T07:45:51.206723+01:00] [debug] >>> testapi::_handle_found_needle: found root-console-top-20200304, similarity 1.00 @ 88/2
[2022-01-17T07:45:51.207059+01:00] [debug] tests/console/check_system_info.pm:89 called testapi::script_run
[2022-01-17T07:45:51.207252+01:00] [debug] <<< testapi::script_run(cmd="zypper lr | tee /tmp/zypperlr.txt", die_on_timeout=-1, timeout=30, quiet=undef, output="")
[2022-01-17T07:45:51.207394+01:00] [debug] tests/console/check_system_info.pm:89 called testapi::script_run
[2022-01-17T07:45:51.207558+01:00] [debug] <<< testapi::type_string(string="zypper lr | tee /tmp/zypperlr.txt", max_interval=250, wait_screen_changes=0, wait_still_screen=0, timeout=30, similarity_level=47)
[2022-01-17T07:45:52.340284+01:00] [debug] tests/console/check_system_info.pm:89 called testapi::script_run
[2022-01-17T07:45:52.340611+01:00] [debug] <<< testapi::type_string(string="; echo 2zsia-\$?- > /dev/ttysclp0\n", max_interval=250, wait_screen_changes=0, wait_still_screen=0, timeout=30, similarity_level=47)
[2022-01-17T07:45:53.507779+01:00] [debug] tests/console/check_system_info.pm:89 called testapi::script_run
[2022-01-17T07:45:53.508115+01:00] [debug] <<< testapi::wait_serial(timeout=30, regexp=qr/2zsia-\d+-/u, expect_not_found=0, no_regex=0, record_output=undef, buffer_size=undef, quiet=undef)
2zsia-0-
[2022-01-17T07:46:23.649555+01:00] [debug] >>> testapi::wait_serial: (?u:2zsia-\d+-): ok

Reproducible

Fails since (at least) Build 31.2

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw 4 months ago

  • Status changed from New to In Progress

#2 Updated by leli 4 months ago

  • Estimated time set to 10.00 h

#4 Updated by coolgw 4 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF