Project

General

Profile

action #104559

test fails in validate_btrfs

Added by dimstar about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-01-03
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-JeOS-for-kvm-and-xen-x86_64-jeos-container_host@64bit_virtio-2G fails in
validate_btrfs

df -h returns:
/dev/vda3 24G 2.1G 22G 9% /var
(used to be 8% in the last runs)

this then does not match the pattern
m[/dev/x?[v,s]d[a-z].+ [0-8][0-9]?%]u;

as the first digit, 0-8, would be mandatory (9 not matching), and only the 2nd digit would be optional (thus 9% is not a valid match)

Test suite description

Container host tests on JeOS image.

Reproducible

Fails since (at least) Build 20220102

Expected result

Last good: 20220101 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dimstar about 1 year ago

 # Ensure the var partition has at least 10% free space
 validate_script_output "df -h | grep var", sub { m/\/dev\/x?[v,s]d[a-z].+ [0-8][0-9]?%/ };

Changing the pattern to sub { m/\/dev\/x?[v,s]d[a-z].+ [1-8]?[0-9]%/ }; would likely be ok (so the first digit is optional,but when present, must be between 1 and 8 (there is only one case where it could be '0', which is the case of 100%; which would never match anyway, as it's not 2-digits preceded by a space)

#2 Updated by dimstar about 1 year ago

  • Status changed from New to Resolved

Also available in: Atom PDF