Project

General

Profile

action #104475

[sle][migration][sle15sp4][regression] integrate btrfsmaintenance test case into regression group

Added by coolgw 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
-
Start date:
2021-12-28
Due date:
% Done:

0%

Estimated time:
12.00 h
Difficulty:

Description

Base maintenance lessons learn we take integration btrfsmaintenance module action
should following poo#65606

Regression in btrfsmaintenance
Bug 1159891 - L3: EMU: btrfs cron jobs source common.sh incorrectly There are 2 issues caused by btrfsmaintenace. First is that btrfsmaintenance-refresh.service creates symlinks at /etc/cron.* that are not deleted when the package is not removed.

Second issue is that 2 scripts (btrfs-balance, btrfs-trim) are incorrectly sourcing /etc/cron.weekly/common.sh, which does not exist.
The fix was to remove symlinks when btrfsmaintenance package is removed, also fixed the broken common.sh PATH.

Steps taken to prevent regression in the future On regression tests, add a step to run crontab scripts and check results on system logs and administrator e-mail.

poo#65606 - opened

History

#1 Updated by coolgw 5 months ago

  • Category set to Enhancement to existing tests

#2 Updated by leli 5 months ago

  • Estimated time set to 12.00 h

#3 Updated by coolgw 5 months ago

  • Assignee set to coolgw

#4 Updated by coolgw 5 months ago

  • Status changed from New to In Progress

#5 Updated by coolgw 4 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF