Project

General

Profile

action #104238

[sle][migration][SLE15SP4]test fails in scc_deregistration - need disable packagekit before any zypper operation

Added by coolgw 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-12-22
Due date:
% Done:

100%

Estimated time:
10.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP4-Migration-from-SLE15-SPx-s390x-offline_SLES_15_SP2_ltss_pscc_basesys-srv-desk_all_full_zVM_preparation@s390x-zVM-Upgrade-m1 fails in
scc_deregistration

Test suite description

The base test suite is used for job templates defined in YAML documents. It has no settings of its own.

Reproducible

Fails since (at least) Build 77.1 (current job)

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by leli 5 months ago

PackageKit is blocking zypper. This happens if you have an updater applet or other software
management application using PackageKit running.
We can ask PackageKit to interrupt the current action as soon as possible, but it depends on
PackageKit how fast it will respond to this request.

We need wait packagekit quit then run SUSEConnect to deregister.

#2 Updated by leli 5 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 30
  • Estimated time set to 12.00 h

Created branch to quit packagekit before deregister system, wait http://openqa.nue.suse.com/tests/7893303#live to verify.

#3 Updated by leli 5 months ago

  • % Done changed from 30 to 50

#4 Updated by leli 5 months ago

  • Estimated time changed from 12.00 h to 10.00 h

#5 Updated by leli 5 months ago

PR merged, wait https://openqa.suse.de/tests/7897889 to verify.

#6 Updated by leli 5 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

Also available in: Atom PDF