Project

General

Profile

action #103485

[sporadic] os-autoinst: flaky test t/13-osutils.t

Added by okurz about 1 month ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-12-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Observed in GHA and
locally

## Run 18
t/13-osutils.t .. 1/?
    #   Failed test 'Exit code appear in log'
    #   at t/13-osutils.t line 167.
    # STDERR:
    # [2021-12-05T11:03:37.186582+01:00] [debug] running `echo foo`
    # [2021-12-05T11:03:37.194499+01:00] [debug] Command `echo foo` terminated with 1
    #   foo
    # 
    # doesn't match:
    # (?^u:terminated with 0)
    # as expected
    # Looks like you failed 1 test of 10.

#   Failed test 'run_diag'
#   at t/13-osutils.t line 190.
# Looks like you failed 1 test of 9.
t/13-osutils.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/9 subtests 

Reproducible

Locally I could only reproduce it in 1/500 (!) runs with runs=500 count_fail_ratio prove -I. t/13-osutils.t

runs=500 count_fail_ratio make test-perl-testsuite WITH_COVER_OPTIONS=1 TESTS=t/13-osutils.t yields

## count_fail_ratio: Run: 500. Fails: 5. Fail ratio 1%

Related issues

Is duplicate of openQA Project - action #103422: [sporadic] os-autoinst: 13-osutils.t:167 Failed test 'Exit code appear in log' in GHA size:MResolved2021-11-30

History

#1 Updated by okurz about 1 month ago

  • Is duplicate of action #103422: [sporadic] os-autoinst: 13-osutils.t:167 Failed test 'Exit code appear in log' in GHA size:M added

#2 Updated by okurz about 1 month ago

  • Status changed from New to Rejected
  • Assignee set to okurz

Also available in: Atom PDF