Project

General

Profile

action #97451

[desktop][sle15sp4] test fails in first_boot; gnome auth window popup on s390x

Added by zcjia 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-08-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Actually this is not a new bug, it happens on sle15sp3 as well: https://openqa.suse.de/tests/5990037#step/xterm/6

Related bug: https://bugzilla.suse.com/show_bug.cgi?id=1177446

Summary: since on s390x, openQA uses vnc to connect instead of vnc provided by qemu, so the refresh-repo auth window popup will appear on s390x first time login instead of other archs.

Solution: change function "handle_login" in lib/x11utils.pm.

openQA test in scenario sle-15-SP4-Online-E-Staging-s390x-ext4_staging_s390x@s390x-kvm-sle12 fails in
first_boot

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Maintainer: QE Kernel, QE Yast

Reproducible

Fails since (at least) Build E.19.2

Expected result

Last good: E.19.2 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by zcjia 3 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF