Project

General

Profile

Actions

action #96122

closed

Errors from hook scripts in openqa-gru service log ("grep: range out of order in character class") size:M

Added by tinita over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
Due date:
2021-08-12
% Done:

0%

Estimated time:

Description

Observation

journalctl -u openqa-gru on osd shows:

Jul 27 20:00:36 openqa openqa-gru[2105]: grep: exceeded PCRE's backtracking limit
Jul 27 20:00:37 openqa openqa-gru[2105]: grep: range out of order in character class

Acceptance criteria

  • AC1: No obvious error messages like the above mentioned in openqa-gru logs

Suggestions

  • openqa-label-known-issues looks like a good candidate because the regular expressions for the grep in label_on_issue come from outside (issue subjects)

Further details

openqa-gru runs multiple asynchronous background processes. The ones mentioned above are from "job_post_hooks".


Related issues 1 (0 open1 closed)

Copied from openQA Project - action #95830: Errors from hook scripts in openqa-gru service log ("parse error: Invalid numeric literal at...", JSON error) size:MResolvedtinita2021-06-242021-08-06

Actions
Actions #1

Updated by tinita over 2 years ago

  • Copied from action #95830: Errors from hook scripts in openqa-gru service log ("parse error: Invalid numeric literal at...", JSON error) size:M added
Actions #2

Updated by ilausuch over 2 years ago

  • Subject changed from Errors from hook scripts in openqa-gru service log ("grep: range out of order in character class") to Errors from hook scripts in openqa-gru service log ("grep: range out of order in character class") size:M
  • Due date deleted (2021-08-10)
  • Status changed from New to Workable
  • Start date deleted (2021-07-27)

We estimated this ticket because is urgent

Actions #3

Updated by tinita over 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to tinita
Actions #4

Updated by openqa_review over 2 years ago

  • Due date set to 2021-08-12

Setting due date based on mean cycle time of SUSE QE Tools

Actions #5

Updated by tinita over 2 years ago

  • Status changed from In Progress to Feedback

PR for logging problematic grep calls: https://github.com/os-autoinst/scripts/pull/96

In a second step, we can see which strings are problematic and how to avoid that.

Actions #6

Updated by tinita over 2 years ago

The PR was merged 4 days ago.
So far I didn't see any grep errors in the logs.

Waiting a bit longer.

Actions #7

Updated by tinita over 2 years ago

  • Status changed from Feedback to Resolved

I can't see a grep error in the logs.
Unfortunately the logs are still quite short, currently I see:

journalctl  --since=2021-08-04 -u openqa-gru -f
-- Logs begin at Sun 2021-07-18 03:30:00 CEST. --
Aug 09 08:30:05 openqa openqa-gru[15072]: unable to clone job 6701666: it is part of a parallel or directly chained cluster (not supported)

So it only goes back to this morning.

The PR only improved the error message, but if I don't see the error in the logs at all, I can't keep this ticket open forever.
Resolving for now.

Actions

Also available in: Atom PDF