Project

General

Profile

action #804

openqa: debug aplay fail

Added by lnussel almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
QA
Target version:
Start date:
2013-09-13
Due date:
2013-10-14
% Done:

100%

Estimated time:
Duration: 22

Description

the aplay test in openqa does not seem to output audio. check if that's a bug in the distro, a openqa bug or qemu bug.

145_aplay.pm (837 Bytes) 145_aplay.pm Fixed test -miska-, 2013-10-18 09:34

History

#1 Updated by lnussel almost 7 years ago

in build 701 some installations succeed the test so strange

#2 Updated by -miska- almost 7 years ago

  • Assignee set to -miska-

Will take a look into this

#3 Updated by -miska- almost 7 years ago

Can reproduce failure locally, many errors from qemu as I don't have a soundcard, trying to reproduce success, getting familiar with what is where

#4 Updated by lnussel almost 7 years ago

coolo ran into an issue an found this by chance:
https://github.com/openSUSE-Team/os-autoinst/commit/559caf82364fa2db9ba7007e74eadc8af94a027d
maybe it's the cause already

#5 Updated by -miska- almost 7 years ago

Didn't helped but so far I was unable to reproduce successful aplay test locally.

#6 Updated by lnussel almost 7 years ago

  • Target version changed from 13.1 Beta 1 to 13.1 RC1

do you have multimon installed?

#7 Updated by lnussel almost 7 years ago

Also, does recording in qemu work in general? You could run a VM after openQA has killed it via the runqemu script in the pool dir. Run the worker with --no-cleanup to have it retain the disk images.

#8 Updated by lnussel almost 7 years ago

looks like it only fails in minimalx

#9 Updated by lnussel almost 7 years ago

  • Due date changed from 2013-09-18 to 2013-10-09

#10 Updated by -miska- almost 7 years ago

No progress about it yet.

#11 Updated by lnussel almost 7 years ago

  • Due date changed from 2013-10-09 to 2013-10-14

#12 Updated by lnussel almost 7 years ago

  • Target version changed from 13.1 RC1 to 13.1 RC2

#13 Updated by -miska- almost 7 years ago

So took a virtual machine after test failed, started it manually and tried to play the same sound and works (verified by listening). Will continue to play with openQA and try to figure out why it didn't worked there, maybe attach soundcard to that computer and listen...

#14 Updated by -miska- almost 7 years ago

Found what the error was, here is a fixed test, needs new needle. It was simply muted.

#15 Updated by lnussel almost 7 years ago

  • Status changed from Feedback to Closed

could you submit a pull request for your change please? credit where credit is due ...

#16 Updated by lnussel almost 7 years ago

  • Status changed from Closed to In Progress
  • % Done changed from 100 to 90

after thinking about it let's keep it open until pull request done

#17 Updated by lnussel almost 7 years ago

Michal, I'm still waiting for the pull request ..

#18 Updated by -miska- almost 7 years ago

Sent pull request, for tests, needles will need update as well.

#19 Updated by -miska- almost 7 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Test and needle are both sent and merged

Also available in: Atom PDF