Project

General

Profile

action #80190

[SLE][Migration][sle15sp3]test fails in patch_sle(wait_serial expected: "GNU GRUB" failed)

Added by coolgw over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-11-23
Due date:
% Done:

0%

Estimated time:
16.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP3-Migration-from-SLE12-SPx-s390x-offline_sles12sp5_pscc_lp_all_full@s390x-kvm-sle12 fails in
patch_sle

Test suite description

Reproducible

Fails since (at least) Build 85.2

Expected result

Last good: 78.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw over 1 year ago

  • Status changed from New to In Progress

#2 Updated by coolgw over 1 year ago

the issue is failed case skip grub menu so following logic failed (opensusebasetest.pm):
wait_serial('GNU GRUB', 180) || diag 'Could not find GRUB screen, continuing nevertheless, trying to boot';
grub_select;

     type_line_svirt '', expect => $login_ready, timeout => $ready_time + 100, fail_message => 'Could not find     login prompt';

we need further check why grub menu not popup since this case can run successfully before.

#3 Updated by coolgw over 1 year ago

  • Status changed from In Progress to Closed

create bsc#1179230 for further tracking this, hold current ticket.

Also available in: Atom PDF