Project

General

Profile

action #71182

OBS package os-autoinst blocked since multiple days on "blocked: downloading 6 dod packages"

Added by okurz 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2020-09-10
Due date:
% Done:

0%

Estimated time:

Description

Observation

Since some days https://build.opensuse.org/package/show/devel:openQA/os-autoinst against "openSUSE_Tumbleweed" is blocked with "blocked: downloading 6 dod packages", any clues what to do/click/read/understand next?
I have already asked in IRC #opensuse-factory as well as #opensuse-buildservice (2x) and opensuse-buildservice@opensuse.org

This is blocking all our pull requests' OBS checks as well as nightly CI builds, e.g. see
https://app.circleci.com/pipelines/github/os-autoinst/openQA/4140/workflows/b8f8e6d2-e949-4095-8d25-c51222a68508/jobs/39590

History

#1 Updated by okurz 11 months ago

desparately trying to fix stuff because I do not get any response, e.g.

osc wipebinaries -r openSUSE_Tumbleweed -a x86_64 devel:openQA os-autoinst

Also tried to disable the build within https://build.opensuse.org/package/meta/devel:openQA/os-autoinst for the repo "openSUSE_Tumbleweed" to no effect (package disappeared and appeared again but again in "blocked").

#2 Updated by okurz 11 months ago

adrianS responded in IRC but we only progressed a little bit:

[10/09/2020 16:02:25] <adrianS> okurz: OBS gets always delivered a broken rpm atm :/
[10/09/2020 16:02:47] <okurz> what does that mean?
[10/09/2020 16:13:03] <adrianS> widehat deliveres another rpm but with same name
[10/09/2020 16:13:10] <adrianS> but different checksum
[10/09/2020 16:14:37] <okurz> and you mean os-autoinst? or a dependency of os-autoinst?
[10/09/2020 16:15:12] <adrianS> qemu-ipxe-1.0.0+-3.1.noarch.rpm
[10/09/2020 16:21:55] <okurz> I assume I would not have the necessary access to find this out.
[10/09/2020 16:26:14] <adrianS> it is currently a generic problem, zypp will fail with same error though
[10/09/2020 16:27:01] <adrianS> but yes, hard to find out about the particular package
[10/09/2020 16:37:27] <okurz> https://build.opensuse.org/package/live_build_log/openSUSE:Factory/qemu/standard/x86_64 mentions that it built this file. I hope that you are planning to do something about the problem as I would not know what to do with the information you provided :)
[10/09/2020 16:38:25] <adrianS> actually, I do not know either
[10/09/2020 16:38:33] <adrianS> it is a broken mirror, not the delivery
[10/09/2020 16:39:25] <-- adrianS (~adrian@opensuse/member/AdrianSuSE) has left this server (Read error: Connection reset by peer).
[10/09/2020 16:39:26] <okurz> and if we would trigger a rebuild and republish of qemu in Factory that could potentially repair it?

#3 Updated by okurz 11 months ago

https://github.com/os-autoinst/openQA/pull/3386 to temporarily exclude the OBS checks

#4 Updated by okurz 11 months ago

  • Status changed from New to In Progress
  • Assignee set to okurz
  • Priority changed from Urgent to Normal

I also asked DimStar to retrigger a build of the qemu package in Factory which should overwrite any faulty RPM files which might exist on download.opensuse.org whenever a new Tumbleweed snapshot would be published. Also I asked coolo to temporarily switch the OBS build checks from building against Tumbleweed to Factory. The new Tumbleweed snapshot with new qemu seems to have unblocked our PRs as some were automatically merged.

Created https://github.com/os-autoinst/openQA/pull/3388 to revert the workaround in mergify.

#5 Updated by okurz 11 months ago

  • Status changed from In Progress to Feedback

official package looks good. Waiting for the PR to be merged.

#6 Updated by okurz 11 months ago

  • Status changed from Feedback to Resolved

done. OBS checks in other PRs are also fine

Also available in: Atom PDF