Project

General

Profile

action #695

Fix automatic documentation issues

Added by ancorgs about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Development
Target version:
Start date:
2013-08-29
Due date:
% Done:

100%

Estimated time:
8.00 h

Description

Use YARD-specific setup and configuration for generating the documentation instead of a custom rake task, so documentation can be nicely integrated in RubyDoc.info. Fix automatic generation of graphviz diagrams from state_machine, which is broken upstream when using some state_machine features as conditions.

History

#1 Updated by ancorgs almost 9 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 30

Digging into the Graphviz problem. I turned out to be a very obscure conflict involving several gems that only shows up in some environments. Weird. Still debugging (after 3 hours).

#2 Updated by ancorgs almost 9 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 30 to 100

Most things moved to .yardopt except some options that could cause an error in rubydoc.info (I'm not sure because rubydoc.info is not refreshing). State_machine patched to fix the graphviz issue. Pull request sent to the original author https://github.com/pluginaweek/state_machine/pull/283 In the meanwhile, state_machine machine is monkey-patched in TSP app, so the problem is gone.

Also available in: Atom PDF