Project

General

Profile

action #68275

[SLE][Migration][SLE15SP3] automation for https://jira.suse.com/browse/ECO-1251?filter=51381

Added by coolgw over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2020-06-22
Due date:
% Done:

100%

Estimated time:
16.00 h
Difficulty:

Description

Once this feature ready we need automation test for this.
[QA Approval] [ECO] Provide NVIDIA CUDA Repo Information thru NVIDIA Compute Module

QA is asked to just ensure that whatever method we provide, the repositories will be added correctly, ie the repository metadata will be read in successfully (ie 'zypper refresh' succeeds).
There is no need for special hardware, there is no need to perform any testing of any software. This is partner provided software, ensuring it to work properly is entirely within the responsibility of the partner.

For more guidance around ECO process, follow:
https://confluence.suse.com/display/SUSE/ECO+Guidance

History

#1 Updated by coolgw about 2 years ago

  • Estimated time set to 25.00 h

#2 Updated by coolgw about 2 years ago

  • Priority changed from Normal to Low

#3 Updated by coolgw almost 2 years ago

  • Priority changed from Low to Normal

#4 Updated by coolgw over 1 year ago

  • Assignee set to zoecao
  • Estimated time changed from 25.00 h to 4.00 h

#5 Updated by coolgw over 1 year ago

  • Estimated time changed from 4.00 h to 16.00 h

update effort since we update scope of this ticket:
1) add nvidia module into current sles regression case
2) add nvidia test case for hpc in regression group

#6 Updated by zoecao over 1 year ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 40

1) add nvidia module into current sles regression case
Added the nvidia to regression SLES15SP2 cases.
Verification case is running: http://openqa.suse.de/t5246529
2) add nvidia test case for hpc in regression group
Added the case to Regression group:
case: online_slehpc15sp2_pscc_basesys-desk-dev-hpc-python2-srv-wsm-nvidia_def_full_zypp_tm
Verification run:http://openqa.suse.de/t5246538
I will update here after the verification runs are finished.

#7 Updated by zoecao over 1 year ago

  • % Done changed from 40 to 60

Update the second task (add hpc regression case) status:
Exclude the service check part and re-cloned a case:
http://openqa.suse.de/tests/5252418#

#8 Updated by zoecao over 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

Moved the SLES+NVIDIA case to milestone group; Added the hpc regression case to regression group:
NVIDIA Compute Module 15 is a service pack independent module, the same module is to be used for all SLE 15 service packs. It has been released and not put into proxySCC, proxySCC only is used for products and modules in development phase. So same with the modules of SLE12, we test it in milestone group.

Also available in: Atom PDF