Project

General

Profile

action #61074

All ppc64le and aarch64 osd workers fail to access external https and devel:languages:go due to cert problems (but not x86_64 and not o3 workers)

Added by okurz 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Start date:
2019-12-17
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Observation

openqaworker-arm-1 on zypper ref:

Checking whether to refresh metadata for telegraf-monitoring
Problem retrieving files from 'telegraf-monitoring'.
Download (curl) error for 'https://download.opensuse.org/repositories/devel:/languages:/go/openSUSE_Leap_15.1/repodata/repomd.xml':
Error code: Curl error 60
Error message: SSL certificate problem: unable to get local issuer certificate

History

#1 Updated by okurz 7 months ago

  • Subject changed from All ppc64le and aarch64 osd workers fail to access devel:languages:go due to cert problems (but not x86_64 and not o3 workers) to All ppc64le and aarch64 osd workers fail to access external https and devel:languages:go due to cert problems (but not x86_64 and not o3 workers)
  • Priority changed from Normal to Urgent

#2 Updated by okurz 7 months ago

  • Status changed from New to In Progress
  • Assignee set to okurz
  • Target version set to Current Sprint

seems the problem is that updates from the updates channel are not installed. Looks like the update repos are wrongly configured on ppc64le and aarch64 machines. Should be http://download.opensuse.org/ports/update/leap/15.1/oss/ and not http://download.opensuse.org/update/leap/15.1/oss/

fixing with

sudo salt -l error --state-output=changes -C 'G@osarch:aarch64 or G@osarch:ppc64le' cmd.run 'sed -i "s@/update/@/ports/update/@" /etc/zypp/repos.d/repo-update* && zypper ref ; zypper --no-refresh -n patch'

and then force-installed the openssl-1_1 update. We still have repo problems, maybe other updates missing, checking later.

#3 Updated by okurz 7 months ago

  • Status changed from In Progress to Resolved

With all patches installed on the next day sudo salt -l error --state-output=changes -C 'G@osarch:aarch64 or G@osarch:ppc64le' cmd.run 'curl -s https://github.com | head -n 3' looks clean as well as zypper ref and zypper patch.

Also available in: Atom PDF