Project

General

Profile

action #53525

Upgrade o3 workers to Leap 15.1

Added by okurz over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
2019-06-26
Due date:
2019-07-20
% Done:

0%

Estimated time:

Description

Follow #50453#note-6


Related issues

Related to openQA Project - action #52451: test incompletes reproducibly in first_boot of krypton-live-install with "Seems like os-autoinst has produced a result which openQA can not display."Resolved2019-05-31

Related to openQA Infrastructure - action #43937: align o3 workers (done: "imagetester" and) "power8" with the others which are currently "transactional-update" hostsResolved2018-11-15

History

#1 Updated by okurz over 2 years ago

  • Related to action #52451: test incompletes reproducibly in first_boot of krypton-live-install with "Seems like os-autoinst has produced a result which openQA can not display." added

#2 Updated by okurz over 2 years ago

Could help with #52451

#3 Updated by okurz over 2 years ago

Starting with openqaworker1. There are currently some qemu jobs running but in the background I can still prepare the upgrade.

#4 Updated by okurz over 2 years ago

Following #50453#note-6 I replaced repos with Leap 15.1 ones, then did a zypper dup --allow-vendor-change within transactional-pkg shell. After reboot I checked that no systemd services failed and also jobs were successfully "starting". However, today in the morning a lot of jobs on o3 were incomplete due to Can't locate object method "set_expected_autoinst_failures" via package "Distribution::Opensuse::Tumbleweed" at /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/products/opensuse/main.pm line 78. as in https://openqa.opensuse.org/tests/969205/file/autoinst-log.txt due to the fact that os-autoinst and openQA got installed from the official Leap 15.1 oss repo instead of devel:openQA.

So I disabled the workers with

systemctl disable --now openqa-worker.target

and fixed that with proper repo permissions within transactional-pkg shell:

zypper mr -p 95 -r 1
zypper mr -p 90 -r 2
zypper dup --allow-vendor-change

and outside the shell:

systemctl enable openqa-worker.target && reboot

checked after reboot that all workers are fine.

#5 Updated by okurz over 2 years ago

  • Related to action #43937: align o3 workers (done: "imagetester" and) "power8" with the others which are currently "transactional-update" hosts added

#6 Updated by okurz over 2 years ago

  • Status changed from In Progress to Blocked

waiting for #52451 first where it is beneficial to keep old workers around.

#7 Updated by okurz over 2 years ago

  • Status changed from Blocked to In Progress

experiment in #52451 conducted, can upgrade further workers, e.g. openqaworker4. Will keep imagetester on Leap 15.0 but set the worker class to "imagetester" only so that we can debug further if necessary.

https://openqa.opensuse.org/tests/977251 triggered as test job on w4 after upgrade. Job started all good, restarted workers so job retriggered.

#8 Updated by okurz over 2 years ago

  • Due date set to 2019-07-20
  • Status changed from In Progress to Feedback

change done on imagetester, waiting for feedback if any regarding debugging.

#9 Updated by okurz over 2 years ago

  • Status changed from Feedback to In Progress

updated https://bugzilla.opensuse.org/show_bug.cgi?id=1137520#c4 that I will do the update now after the due date was reached.

#10 Updated by okurz over 2 years ago

  • Status changed from In Progress to Resolved

imagetester is back online, upgraded, worker class back to qemu_x86_64, test job started to execute fine.

Also available in: Atom PDF