Project

General

Profile

action #50153

[qam] [blue] test fails in zziplib - missing dependencies for the test

Added by bfilho about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-04-08
Due date:
2019-04-10
% Done:

100%

Estimated time:
Difficulty:
easy
Duration: 3

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-mau-extratests@64bit fails in
zziplib

Test suite description

Run console tests against aggregated test repo

Reproducible

Test was added today to general builds, but it seems it is missing dependencies (and might not be applicable to) 12 SP1 and SP2. Would you guys please check it?
Referred pr is: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7095

Fails since (at least) Build 20190408-2 (current job)

Expected result

Last good: 20190408-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by martinsmac about 1 year ago

  • Subject changed from [qam] test fails in zziplib - missing dependencies for the test to [qam] [blue] test fails in zziplib - missing dependencies for the test
  • Due date set to 2019-04-10
  • Status changed from New to In Progress
  • Assignee set to martinsmac
  • % Done changed from 0 to 80
  • Difficulty set to easy

Issues occurs because SLES 12 sp1/sp2 doesn't have SDK repo.

Changes in zziplib.pm:
Added a conditional to add a SDK repos to SLES 12 Sp1/sp2 until install zziplib-devel
+++
# SLES 12 SP1 and Sp2 need add repo SDK manually
if (is_sle('=12-SP1')) {
assert_script_run "SUSEConnect -p sle-sdk/12.1/x86_64";
}
elsif (is_sle('=12-SP2')) {
assert_script_run "SUSEConnect -p sle-sdk/12.2/x86_64";
}

Tests in:
SLES 12 Sp1 - http://10.161.229.197/tests/363#step/zziplib/1
SLES 12 Sp4 - http://10.161.229.197/tests/364#step/zziplib/1

#2 Updated by martinsmac about 1 year ago

PR Created:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7242

Changes to skip SLES 12 SP1 and SP2 by LTSS doesn't use SDK repos.

#3 Updated by martinsmac about 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

Resolved using this line in main_common.lib:
loadtest 'console/zziplib' if (is_sle('12-SP3+') && !is_jeos);

Also available in: Atom PDF