Project

General

Profile

action #44279

[sle][migration][SLE15SP1]test fails in snapper_rollback

Added by coolgw almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-11-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

This issue seems caused by latest change
commit 2640936e48b6091b301b5eec0b7d23bc361d82fc
Author: rustberry 34592958+rustberry@users.noreply.github.com
Date: Thu Nov 15 17:42:35 2018 +0800

Python3 scripts shall be piped to correct interpreter

diff --git a/lib/migration.pm b/lib/migration.pm
index 24c6a53fe..b08975412 100644
--- a/lib/migration.pm
+++ b/lib/migration.pm
@@ -148,7 +148,7 @@ sub check_rollback_system {
assert_script_run("zypper mr -d -m cd -m dvd");
# Verify registration status matches current system version
# system is un-registered during media based upgrade

  • assert_script_run('curl -s ' . data_url('console/check_registration_status.py') . ' | python') unless get_var('MEDIA_UPGRADE');
  • assert_script_run('curl -s ' . data_url('console/check_registration_status.py') . ' | python3') unless get_var('MEDIA_UPGRADE'); <==== }

# Reset tty for x11 and root consoles

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-TEST-x86_64-0001offline_sles12sp3_pscc_sdk_all_full@64bit fails in
snapper_rollback

Reproducible

Fails since (at least) Build 96.7

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw almost 4 years ago

  • Assignee set to coolgw

#2 Updated by ZejinXu almost 4 years ago

  • Status changed from New to In Progress
  • Assignee changed from coolgw to ZejinXu

#3 Updated by ZejinXu almost 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF