Project

General

Profile

action #37719

[qam][sle-15] test fails in java

Added by osukup about 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-06-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Server-DVD-Updates-x86_64-mau-extratests@64bit fails in
java

Reproducible

Fails since (at least) Build 20180622-2

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pgeorgiadis about 3 years ago

  • Status changed from New to Rejected

in SLE15, we have 3 java version installed:

d81:~ # update-alternatives --list java
/usr/lib64/jvm/jre-1.8.0-ibm/bin/java
/usr/lib64/jvm/jre-1.8.0-openjdk/bin/java
/usr/lib64/jvm/jre-10-openjdk/bin/java

but, the test identifies only two java compilers:

d81:~ # update-alternatives --list javac
/usr/lib64/jvm/java-1.8.0-openjdk/bin/javac
/usr/lib64/jvm/java-10-openjdk/bin/javac

At first impression, one would say that the appropriate devel package is missing. Yet it's not. It's perfectly installed:

d81:~ # rpm -q java-1_8_0-ibm-devel
java-1_8_0-ibm-devel-1.8.0_sr5.11-1.5.x86_64

Then, one would probably think that java compiler is not part of this package, yet it is:

d81:~ # rpm -ql java-1_8_0-ibm-devel | grep javac
/usr/lib64/jvm/java-1.8.0-ibm-1.8.0/bin/javac

The bug is that the update-alternatives --list javac does not know about it, but imho it should. This looks like a product bug rather than a problem in the test. I will close this ticket, but feel free to re-open it if my logic above is wrong.

#2 Updated by pluskalm about 3 years ago

This seems to be caused same issue as in https://bugzilla.suse.com/show_bug.cgi?id=1096420

Also available in: Atom PDF