Project

General

Profile

action #36319

[QAM][CAASP] Use salt grains to let Velum orchestrate the reboot

Added by pgeorgiadis about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-05-17
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

Right now we manually trigger the update of the cluster using system.reboot state in Salt. This is not the right way to do it. We have to use the transactional-update salt pkg install and then take it from Velum.

e.g.

1. Log in to admin node
2. Install the package like this:
docker exec -i $(docker ps | grep salt-master | awk '{print $1}') salt --batch 20 -P "roles:(admin|kube-(master|minion))" cmd.run "/usr/sbin/transactional-update salt pkg install -y $pkg"
3. Wait 10 minutes or refresh the grains right away:
docker exec -i $(docker ps | grep salt-master | awk '{print $1}') salt --batch 20 '*' saltutil.refresh_grains
4. Open Firefox and go to Velum and the rest are the same.

openQA test in scenario caasp-2.0-CaaSP-DVD-Incidents-x86_64-QAM-CaaSP-controller@qam-caasp_x86_64 fails in
stack_update

Reproducible

Fails since (at least) Build :7156:hyper-v.1526320658 (current job)

Expected result

Last good: :7413:kernel-ec2.1526451388 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pgeorgiadis about 3 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100

#2 Updated by pgeorgiadis almost 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF