Project

General

Profile

action #23840

[sle][qam][x11regressions] qam-regression-documentation can't be started due to a void test_flags in gnote_first_run.pm

Added by qkzhu about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-09-01
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

all qam-regression-documentation can't be started successfully (https://openqa.suse.de/tests/1140513) due to:

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3494/files#diff-71e50855a941054df11c4464aba24389R34

I defined a test_flags in gnote_first_run.pm:
sub test_flags {
return {milestone => 1} if (is_tumbleweed);
}
It will return nothing on non tumbleweed scenarios, however it needs a return value.

Maybe I should drop the if sentence.

History

#1 Updated by qkzhu about 5 years ago

Update cases of regression-documentation to fix poo#23840

  • Update gnote_first_run.pm to fix poo#23840
  • Update main_common.pm to reduce complexity
  • Fix typo in libreoffice_recent_documents.pm

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3508

#2 Updated by qkzhu about 5 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF