Project

General

Profile

action #2322

Issue in production server: mails with 1970-01-01

Added by ancorgs over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
Development
Target version:
-
Start date:
2014-04-14
Due date:
% Done:

100%

Estimated time:
1.00 h

Description

In the production server, mails about the state of a request/reimbursement starts with
"Request #X is in y state since Thu, 01 Jan 1970 01:00:00 +0100"

The rest of the information (including dates) in the mail looks fine. Not reproducible locally.

History

#1 Updated by ancorgs over 8 years ago

  • Category set to Development
  • Status changed from New to In Progress

One hour debugging the error directly in production server with no success. It only happens there and only when sending mail "asynchronous" (delayed job). It's driving me crazy.

#2 Updated by ancorgs over 8 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Looks like some problem with (de)serialization into YAML... or not. In any case, I implemented https://github.com/openSUSE/travel-support-program/commit/35bdfb59938909781e1ba445eca84bc4f553d967 as a workaround and it's working properly now.

Also available in: Atom PDF