Project

General

Profile

action #18410

[qam][x11regressions] Close libreoffice test file timely

Added by qkzhu over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-04-07
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP1-Desktop-DVD-Updates-x86_64-qam-regression-documentation@64bit fails in
libreoffice_open_specified_file

libreoffice_open_specified_file and libreoffice_double_click_file are unreliable.
It seems that the VM's performance doesn't support opening so many test files at the same time.
Maybe we could close every 3 or 5 files to reduce the VM's burden.

Reproducible

Fails since (at least) Build 20170407-2 (current job)

Expected result

Last good: 20170407-1 (or more recent)

History

#1 Updated by qkzhu over 5 years ago

  • Status changed from New to In Progress

Update two libreoffice cases to fix poo#18410

libreoffice_open_specified_file and libreoffice_double_click_file are
unreliable. It seems that the VM's performance doesn't support opening
so many test files at the same time.

  • libreoffice_double_click_file
    Open a test file then close it immediately.

  • libreoffice_open_specified_file
    Close every 3 files to reduce the VM's burden and test open multiple files.

    see also: poo18410

Verification test:
SP1: http://147.2.212.115/tests/554
SP2: http://147.2.212.115/tests/555
SP3: http://147.2.212.115/tests/545

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2747

#2 Updated by qkzhu over 5 years ago

  • Status changed from In Progress to Resolved

Passed on o.s.d:

SP1: https://openqa.suse.de/tests/882984
SP2: https://openqa.suse.de/tests/884246
SP3: https://openqa.suse.de/tests/883333

Please feel free to reopen if it still occurs.

Also available in: Atom PDF