Project

General

Profile

Actions

action #157879

closed

[qe-core][functional]test fails in apache, can't read /usr/share/doc/packages/apache2/httpd.conf.default: No such file or directory

Added by rfan1 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2024-03-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Need to double check if the file location is changed or a product bug.\

Observation

openQA test in scenario sle-15-SP6-Online-x86_64-default@64bit fails in
apache

Test suite description

Maintainer: QE Core

The standard scenario where we mainly just follow installation suggestions without any adjustments.

Reproducible

Fails since (at least) Build 67.1

Expected result

Last good: 64.2 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #2

Updated by zluo 2 months ago

Actions #3

Updated by rfan1 about 2 months ago

Seems the issue is not 100% same as mentioned in bsc#1221775

The job can pass with some code changes:

https://openqa.suse.de/tests/13872532#details
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/18953/files


There are some changes which need to check with developer:

  1. /usr/share/doc/packages/apache2/conf/extra/httpd-default.conf is the new default config file and some contexts are changed as well
  2. 'httpd2-prefork' now changes to 'httpd-prefork' # rpm -ql apache2-prefork-2.4.58-150600.1.1.x86_64 |grep 'usr/sbin'|grep prefork /usr/sbin/httpd-prefork
Actions #4

Updated by zluo about 2 months ago

updated in bug report and confirmed that with https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/18953 can fix the issue of apache2 test on openQA.
Further I cannot reproduced the issue on my RPi with jeos latest build. Apache2 is working without issue.

Actions #6

Updated by rfan1 about 2 months ago

  • Status changed from New to Resolved
  • Assignee set to rfan1
Actions

Also available in: Atom PDF