Project

General

Profile

action #14968

repo-checker can miss cycles

Added by dimstar about 6 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
Development
Target version:
-
Start date:
2016-11-23
Due date:
% Done:

0%

Estimated time:

Description

We had the case today where two packages, coming from the same devel repo (libpsl and publicsuffix) caused a cycle (also seen in the devel prj)

repo-checker 'approved' both independent, before they were added to a staging project

Once added to the staging, the group was not being re-checked and the cycle would have gone in unnoticed (I had a gut feeling on it and manually retested the group - the cycle was observed)

We need to come up with a different logic here, like maybe only doing repo-checker cycle tests once a package was added to any staging (be it adi or normal). Potentially a recheck would be needed when packages move between stagings?

The floor is open for discussion

History

#1 Updated by mlin7442 about 6 years ago

I'd go this way,

re-add factory-repo-checker review to the request when execution of select/select --move/adi if there is no factory-repo-checker review opened on the request(ie. maybe approved by repo-checker already). at least under this way, it should makes sense when we force accept an factory-repocher-reviewed-request from backlog without stage it.

#2 Updated by mlin7442 almost 6 years ago

  • Priority changed from Normal to Low

without an reproducible request is hard to fix... down to low prio.

#3 Updated by boombatower over 5 years ago

  • Status changed from New to Rejected

Should be resolved by the new repo_checker since it only looks at requests in stagings and approves the group together. https://github.com/openSUSE/osc-plugin-factory/pull/964

Also available in: Atom PDF