Project

General

Profile

Actions

action #134279

closed

jenkins build submit-openQA-TW-to-oS_Fctry failed

Added by tinita 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2023-08-15
Due date:
% Done:

0%

Estimated time:

Description

Observation

We were notified by email about this failure:
http://jenkins.qa.suse.de/job/submit-openQA-TW-to-oS_Fctry/909/console

+ osc service wait devel:openQA/openQA
Traceback (most recent call last):
  File "/usr/bin/osc", line 11, in <module>
    load_entry_point('osc==1.3.0', 'console_scripts', 'osc')()
  File "/usr/lib/python3.6/site-packages/osc/babysitter.py", line 234, in main
    sys.exit(run(commandline.OscMainCommand()))
  File "/usr/lib/python3.6/site-packages/osc/babysitter.py", line 69, in run
    prg.main(argv)
  File "/usr/lib/python3.6/site-packages/osc/commandline.py", line 545, in main
    cmd.run(args)
  File "/usr/lib/python3.6/site-packages/osc/commandline.py", line 241, in run
    cmd.run(args)
  File "/usr/lib/python3.6/site-packages/osc/commandline.py", line 489, in run
    self.func(args.command, args, *args.positional_args)
  File "/usr/lib/python3.6/site-packages/osc/commandline.py", line 7658, in do_service
    print(waitservice(apiurl, project, package))
  File "/usr/lib/python3.6/site-packages/osc/core.py", line 7237, in waitservice
    u = makeurl(apiurl, ['source', prj, package], query={'cmd': 'waitservice'})
  File "/usr/lib/python3.6/site-packages/osc/core.py", line 3611, in makeurl
    return urlunsplit((scheme, netloc, '/'.join([path] + list(l)), query, ''))
TypeError: sequence item 2: expected str instance, NoneType found
+ rm -rf /tmp/os-autoinst-obs-auto-submit-57IF
Build step 'Execute shell' marked build as failure

The build before that already failed with the same error. http://jenkins.qa.suse.de/job/submit-openQA-TW-to-oS_Fctry/908/console

Actions #1

Updated by tinita 8 months ago

  • Description updated (diff)
Actions #2

Updated by tinita 8 months ago

  • Status changed from New to In Progress
  • Assignee set to tinita
Actions #3

Updated by tinita 8 months ago

It looks like the usage of osc service wait changed:

man osc

osc service wait [PROJECT PACKAGE]

but we're doing osc service wait devel:openQA/openQA, so maybe this was supported in the past, and deprecated, and now got removed.

Actions #4

Updated by tinita 8 months ago

Actions #5

Updated by tinita 8 months ago

  • Status changed from In Progress to Feedback

https://github.com/os-autoinst/scripts/pull/259 merged.
The next jenkins build should work since it gets the script directly from github.

I triggered a build now.

Actions #6

Updated by tinita 8 months ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF