Project

General

Profile

action #114854

[qem][qe-core][aarch64]test fails in yast2_nfs_server, took to long time to get return in serial terminal with ( journalctl -fu nfs-server -o short-precise > /dev/ttyAMA0 & )

Added by rfan1 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-08-01
Due date:
% Done:

100%

Estimated time:
6.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP4-Server-DVD-Updates-aarch64-qam-minimal+base@aarch64-virtio fails in
yast2_nfs_server

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml.

Reproducible

Fails since (at least) Build 20220726-1

Expected result

Last good: 20220725-1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #115079: [qe-core][qem&functional] Many test failures due to low performance on arm workersNew2022-08-08

History

#1 Updated by rfan1 8 months ago

Add timeout=90 and re-run the job, let us see:

# openqa-clone-job  --from http://openqa.suse.de --host http://openqa.suse.de  9236831  _GROUP_ID=0 -skip-download --skip-chained-deps BUILD=rfan_nfs  CASEDIR=https://github.com/rfan1/os-autoinst-distri-opensuse.git#yast2_nfs_server_timeout
Created job #9239272: sle-15-SP4-Server-DVD-Updates-aarch64-Build20220728-1-qam-minimal+base@aarch64-virtio -> http://openqa.suse.de/t9239272

#2 Updated by rfan1 8 months ago

  • Status changed from New to In Progress
  • Assignee set to rfan1
  • Target version set to QE-Core: Ready

Rerun with the latest 0801 drop
http://openqa.suse.de/tests/9241427#

#3 Updated by rfan1 8 months ago

  • % Done changed from 0 to 30

#4 Updated by rfan1 8 months ago

Seems adding timeout can't fix the issue.

I compared the log for passed one and failed one:


( journalctl -fu nfs-server -o short-precise > /dev/ttyAMA0 & ); echo WbUNu-$?-# ( journalctl -fu nfs-server -o short-precise > /dev/ttyAMA0 & ); echo WbUNu-$?-
WbUNu-0-
pwMn0-0-
# clear
( journalctl -fu nfs-server -o short-precise > /dev/ttyAMA0 & ); echo WbUNu-$?-

Seems the command can't get any return there. debugging now...

#5 Updated by rfan1 8 months ago

  • Subject changed from [qem][qe-core][aarch64]test fails in yast2_nfs_server, timeout=30 seems not be enough to [qem][qe-core][aarch64]test fails in yast2_nfs_server, took to long time to get return in serial terminal with ( journalctl -fu nfs-server -o short-precise > /dev/ttyAMA0 & )
  • Estimated time set to 6.00 h

I found some clue here:

http://openqa.suse.de/tests/9250626/logfile?filename=serial_terminal.txt

clear

( journalctl -fu nfs-server -o short-precise > /dev/ttyAMA0 & ); echo qBERp-$?-
zypper -n in mariadb | cat; ( exit ${PIPESTATUS[0]} ); echo 7UoWa-$?-# ( journalctl -fu nfs-server -o short-precise > /dev/ttyAMA0 & ); echo qBERp-$?-

qBERp-0-

I can suppose that serial is busy there and ( journalctl -fu nfs-server -o short-precise > /dev/ttyAMA0 & ) may take some time to get return.

Let me try to use "enter_cmd" instead of "script_run"

#6 Updated by rfan1 8 months ago

The change can give better results. however, new random issue seen:

https://openqa.suse.de/tests/9251582#step/yast2_nfs_server/52

Seems the original issue is gone, but it may still need some time to get the shared information via exportfs cmd.

Let me add one more retry there.

#7 Updated by rfan1 8 months ago

  • % Done changed from 30 to 70

#8 Updated by rfan1 8 months ago

  • Related to action #115079: [qe-core][qem&functional] Many test failures due to low performance on arm workers added

#10 Updated by rfan1 8 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 70 to 90

#11 Updated by rfan1 8 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100

The test passed in the latest openQA run:
https://openqa.suse.de/tests/9318462

Also available in: Atom PDF