Project

General

Profile

action #112430

[qa-tools] [qem-bot] Incident schedule fails in preparation Incident instance

Added by osukup about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
Start date:
2022-06-14
Due date:
% Done:

0%

Estimated time:

Description

from log:

INFO: 2022-06-14 17:03:40.405480: http://download.suse.de/ibs/SUSE:/Maintenance:/24419/SUSE_Updates_SLE-WE_12-SP5_x86_64/repodata/repomd.xml not found -- skip incident
INFO: Project SUSE:Maintenance:24419 can't calculate repohash  .. skipping
INFO: Project SUSE:Maintenance:24462 has empty channels - check incident in SMELT
Traceback (most recent call last):
  File "./qem-bot/bot-ng.py", line 7, in <module>
    main()
  File "/builds/qa-maintenance/bot-ng/qem-bot/openqabot/main.py", line 41, in main
    sys.exit(cfg.func(cfg))
  File "/builds/qa-maintenance/bot-ng/qem-bot/openqabot/args.py", line 24, in do_incident_schedule
    bot = OpenQABot(args)
  File "/builds/qa-maintenance/bot-ng/qem-bot/openqabot/openqabot.py", line 23, in __init__
    self.incidents = get_incidents(self.token)
  File "/builds/qa-maintenance/bot-ng/qem-bot/openqabot/loader/qem.py", line 41, in get_incidents
    xs.append(Incident(i))
  File "/builds/qa-maintenance/bot-ng/qem-bot/openqabot/types/incident.py", line 27, in __init__
    for r in incident["channels"]
  File "/builds/qa-maintenance/bot-ng/qem-bot/openqabot/types/incident.py", line 25, in <listcomp>
    for p, v, a in (
ValueError: not enough values to unpack (expected 3, got 2)

History

#1 Updated by osukup about 2 months ago

  • Priority changed from Normal to Urgent

caused by SUSE:Maintenance:24646

#2 Updated by osukup about 2 months ago

  • Status changed from New to In Progress

#3 Updated by okurz about 2 months ago

  • Tags set to reactive work
  • Target version set to Ready

#4 Updated by osukup about 2 months ago

  • Status changed from In Progress to Feedback

changes merged, bot should now work correctly with opeSUSE-Micro-Leap and if naming and structure of openSUSE part stays same also with future changes

#5 Updated by okurz about 2 months ago

where have you found the log that you posted in the description? I assume a failing job from gitlab CI? Could you please link it?

#6 Updated by osukup about 2 months ago

  • Status changed from Feedback to Resolved

for example https://gitlab.suse.de/qa-maintenance/bot-ng/-/jobs/1015822

now fixed, and bot works .

Also available in: Atom PDF