Project

General

Profile

action #112199

[sle][migration][sle15sp5][SAP] recreate all qcow files for SAP and verify all new qcow files for sap job

Added by coolgw 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-06-08
Due date:
% Done:

100%

Estimated time:
20.00 h
Difficulty:

Description

Observation

This task used to verify the create qcow process for sap migration job , include all qcows which will be used for 15sp5.
You can refer following ticket which already verify one of qcow.
https://progress.opensuse.org/issues/111953

Test suite description

Reproducible

Fails since (at least) Build 98.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by hjluo 2 months ago

12sp5:
x86_64
the job https://openqa.nue.suse.com/tests/8898056 created qcow file:
sle-12-SP5-x86_64-sap-nw-noscc.qcow2

verify case: https://openqa.nue.suse.com/tests/8905981 PASSED

./hj-tools/hj-clone.sh -j 8898056 -s "_GROUP=0 PUBLISH_HDD_1=sle-12-SP5-ppc64le-sap-nw-noscc-atm.qcow2 ISO=SLE-12-SP5-SAP-DVD-ppc64le-GM-DVD1.iso VERSION=12-SP5 "
https://openqa.nue.suse.com/t8930864
12SP5 ppc64le:
https://openqa.nue.suse.com/tests/8945568

https://openqa.nue.suse.com/t8945899
Verify case: https://openqa.nue.suse.com/t8950686 PASSED

#2 Updated by hjluo 2 months ago

12sp3 x86:
./hj-tools/hj-clone.sh -j 8898056 -s "_GROUP=0 PUBLISH_HDD_1=sle-12-SP3-x86_64-sap-nw-noscc-atm.qcow2 ISO=SLE-12-SP3-SAP-DVD-x86_64-GM-DVD1.iso VERSION=12-SP3 "
https://openqa.nue.suse.com/t8921629

Verify case: https://openqa.nue.suse.com/t8950730 PASSED

ppc64le:

./hj-tools/hj-clone.sh -j 8945568 -s "_GROUP=0 PUBLISH_HDD_1=sle-12-SP3-ppc64le-sap-nw-noscc-atm.qcow2 ISO=SLE-12-SP3-SAP-DVD-ppc64le-GM-DVD1.iso VERSION=12-SP3"
https://openqa.nue.suse.com/t8945588

Verify case: https://openqa.nue.suse.com/t8950684 PASSED

#3 Updated by hjluo 2 months ago

12sp4
./hj-tools/hj-clone.sh -j 8898056 -s "_GROUP=0 PUBLISH_HDD_1=sle-12-SP4-x86_64-sap-nw-noscc-atm.qcow2 ISO=SLE-12-SP4-SAP-DVD-x86_64-GM-DVD1.iso VERSION=12-SP4 "
https://openqa.nue.suse.com/t8922027

Verify case: https://openqa.nue.suse.com/t8950746 PASSED

PASSED
./hj-tools/hj-clone.sh -j 8945568 -s "_GROUP=0 PUBLISH_HDD_1=sle-12-SP4-ppc64le-sap-nw-noscc-atm.qcow2 ISO=SLE-12-SP4-SAP-DVD-ppc64le-GM-DVD1.iso VERSION=12-SP4 "

https://openqa.nue.suse.com/t8945589
Verify case: https://openqa.nue.suse.com/t8950685 PASSED

#4 Updated by hjluo 2 months ago

15sp1 x86_64:
./hj-tools/hj-clone.sh -j 8898056 -s "_GROUP=0 PUBLISH_HDD_1=sle-15-SP1-x86_64-sap-nw-noscc-atm.qcow2 ISO=SLE-15-SP1-Installer-DVD-x86_64-GM-DVD1.iso VERSION=15-SP1"
https://openqa.nue.suse.com/t8945635

https://openqa.nue.suse.com/tests/8950732#downloads

recreate with QEMU_VIRTIO_RNG=0
https://openqa.nue.suse.com/t8956972 verify case: https://openqa.nue.suse.com/t8957104 PASSED

Verify case: https://openqa.nue.suse.com/t8950728 FAILED
https://openqa.nue.suse.com/t8950816 PASSED
https://openqa.nue.suse.com/t8950817 FAILED
recreated qcow file and rerun: https://openqa.nue.suse.com/t8950876

Verifying
./hj-tools/hj-clone.sh -j 8950728 -s "_GROUP=0 QEMU_VIRTIO_RNG=0"
https://openqa.nue.suse.com/t8956843

15sp1 ppc64le:
./hj-tools/hj-clone.sh -j 8945568 -s "_GROUP=0 PUBLISH_HDD_1=sle-15-SP1-ppc64le-sap-nw-noscc-atm.qcow2 ISO=SLE-15-SP1-Installer-DVD-ppc64le-GM-DVD1.iso VERSION=15-SP1 NOVIDEO=0"

https://openqa.nue.suse.com/t8945800

Verify case: https://openqa.nue.suse.com/t8950681 PASSED

#5 Updated by hjluo 2 months ago

15sp2 x86:
https://openqa.nue.suse.com/t9003525
QEMUVGA=virtio QEMU_VIRTIO_RNG=0
Verify case: https://openqa.nue.suse.com/tests/9003665 PASSED

15sp2 ppc64le:
./hj-tools/hj-clone.sh -j 8945568 -s "GROUP=0 PUBLISH_HDD_1=sle-15-SP2-ppc64le-sap-nw-noscc-atm.qcow2 ISO=SLE-15-SP2-Installer-DVD-ppc64le-GM-DVD1.iso VERSION=15-SP2 ISO_MAXSIZE=11619977728"
https://openqa.nue.suse.com/t8945803
Verify case: https://openqa.nue.suse.com/t8950667 __PASSED
_

15sp3 x86:
"QEMUVGA=virtio QEMU_VIRTIO_RNG=0"
https://openqa.nue.suse.com/t9003295

Verify case:
https://openqa.nue.suse.com/t9003615 PASSED

15sp3 ppc64le:
./hj-tools/hj-clone.sh -j 8945568 -s "GROUP=0 PUBLISH_HDD_1=sle-15-SP3-ppc64le-sap-nw-noscc-atm.qcow2 ISO=SLE-15-SP3-Installer-DVD-ppc64le-GM-DVD1.iso VERSION=15-SP3 ISO_MAXSIZE=13208570368"
https://openqa.nue.suse.com/t8945808
Verify case: https://openqa.nue.suse.com/t8950661 __PASSED
_

#6 Updated by hjluo 2 months ago

  • Subject changed from [sle][migration][sle15sp5][SAP] verfication on new qcow create for sap job to [sle][migration][sle15sp5][SAP] re-create all qcow files for SAP and verify all new qcow files for sap job

#7 Updated by hjluo 2 months ago

added media type and flavor for ppc64le in
https://openqa.nue.suse.com/admin/job_templates/316?

#8 Updated by hjluo about 2 months ago

Now verify all x86 and ppc64 case, now the issue is that for 15sp2/15sp3 we can't switch to tty6. it's freeze there, need to check why.

#9 Updated by hjluo about 2 months ago

filed bug Bug 1200560 [Build 151.1] openQA test fails in patch_sle - switch tty failed and the screen freeze
for 15sp2 and 15sp3

#11 Updated by hjluo about 2 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

all qcow2 files were recreated and verified.

#12 Updated by hjluo about 1 month ago

  • Subject changed from [sle][migration][sle15sp5][SAP] re-create all qcow files for SAP and verify all new qcow files for sap job to [sle][migration][sle15sp5][SAP] recreate all qcow files for SAP and verify all new qcow files for sap job

Also available in: Atom PDF