Project

General

Profile

action #110262

openqa_review: Github action failed with "tox4: command not found"

Added by jbaier_cz 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2022-04-25
Due date:
% Done:

0%

Estimated time:

Description

Seen on https://github.com/os-autoinst/openqa_review/actions/runs/2041575981

The tox invocation started to fail on every Python version but 3.6 with a message tox4: command not found; replacing tox4 with tox will do the opposite and succeeds on every Python version but 3.6 where it fails with tox: command not found. Likely, this is caused by a dependency change as the new (failing) jobs includes tox-3.25.0, the previous (non-failing) used tox-3.24.5.

AC1: The pipeline succeeds on every defined Python version

History

#1 Updated by jbaier_cz 2 months ago

Also: why the hell is the binary named tox4, if the version is 3.x? Unfortunately, using version tox-4.0.0b2 will not make any difference.

#3 Updated by jbaier_cz 2 months ago

  • Status changed from New to In Progress
  • Assignee set to jbaier_cz

#4 Updated by jbaier_cz 2 months ago

  • Status changed from In Progress to Feedback

It seems, that the problem was caused infact by the tox-gh (and how the support for tox v4 was handled). This should be solved by making a transition to tox-gh-actions as suggested in https://github.com/os-autoinst/openqa_review/pull/213

#5 Updated by jbaier_cz 2 months ago

  • Status changed from Feedback to Resolved

Pipeline looks good, no issues reported.

Also available in: Atom PDF