Project

General

Profile

action #94534

[qem][qe-core] test fails in scc_registration

Added by mgrifalconi 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-06-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

TL;DR Sometimes it needs Yes, sometimes Trust. We should handle both cases.

The issue:

openQA test in scenario sle-15-SP2-Server-DVD-Updates-x86_64-qam-textmode+sle15@64bit fails in
scc_registration

Test suite description

Reproducible

Fails since (at least) Build 20210623-1 (current job)

Expected result

Last good: 20210622-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by mgrifalconi 11 months ago

Chat with lslezak on IRC #yast

mich_: it might be actually caused by changes on the server, one dialog is "import untrusted key" the other one is "unknown key", I guess the GPG key was not published at the second case
mich_: very likely the nvidia repo was broken/incomplete at that time
mich_: as this is a 3rd party server we cannot guarantee anything so I think it would be better to support both cases in the test

#2 Updated by mgrifalconi 11 months ago

  • Description updated (diff)

#3 Updated by mgrifalconi 11 months ago

New PR to go back to alt-t as temporary fix. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12779

We should be able to handle both cases without changing the code all the times.

Simple fix: Send both keys (alt-y and alt-t), maybe the second only if the first do not work as intended
Another way: recognize what key is needed by creating a lot of new needles

Of course other ideas are welcome :)

#4 Updated by okurz 11 months ago

Sending both keys is what I had in mind as well. On the other hand if you need "a lot of new needles" you would do it wrong, both cases had been in there in before. Maybe only need to add specific tags to distinguish. The complete amount of needles should not exceed 8: ncurses/GUI*yes/trust/no/cancel

#5 Updated by okurz 11 months ago

  • Status changed from New to Feedback
  • Assignee set to okurz

#6 Updated by okurz 11 months ago

  • Status changed from Feedback to Resolved

PR merged. Hard to verify both cases as that would depend on the state in external repos which we don't have under our control. However we can at least verify one of two cases, e.g. https://openqa.suse.de/tests/6329671#step/scc_registration/38

Also available in: Atom PDF