Project

General

Profile

action #94240

[Leap15.3] [Desktop] test fails in updates_packagekit_gpk

Added by msmeissn 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-06-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.3-DVD-Updates-x86_64-gnome@uefi fails in
updates_packagekit_gpk

Test suite description

Reproducible

Fails since (at least) Build 20210615-2

Expected result

Last good: 20210615-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by msmeissn 3 months ago

i think the alt-i keypress no longer works or something else is borked

#2 Updated by maritawerner 3 months ago

  • Subject changed from test fails in updates_packagekit_gpk to [Desktop] test fails in updates_packagekit_gpk
  • Assignee set to GraceWang

Hello Grace, could you look into that? Coolo is listed as the maintainer but he is now focusint on other tasks.

#3 Updated by GraceWang 3 months ago

maritawerner Sure, I will look into this issue. Since I am not the author of this test case, so it might take time to fix it. But I will try to fix it quickly since the Priority is Urgent.

#4 Updated by GraceWang 3 months ago

  • Subject changed from [Desktop] test fails in updates_packagekit_gpk to [Leap15.3] [Desktop] test fails in updates_packagekit_gpk
  • Status changed from New to Blocked

Checked the latest few results, and found this looks more like a product issue, not a test case issue.

From the openQA we can see: install all the updates from gpk-update-viewer works fine (See https://openqa.opensuse.org/tests/1800799#step/updates_packagekit_gpk/32)
and restart gpk-update-viewer also works fine.

The problem is: after installing all the updates, there is "Recommended update for libreoffice and xmlsec1" available.
And try to install "Recommended update for libreoffice and xmlsec1" failed. What I say failed means that after installation of the update, the update item is still shown in the list.

Based on the above analyze, I filed a bug to track this issue https://bugzilla.opensuse.org/show_bug.cgi?id=1187642

#5 Updated by punkioudi 3 months ago

Similar situation happens in updates_packagekit_kde : https://openqa.opensuse.org/tests/1809611#step/updates_packagekit_kde/36, where while all the updates have been finished, it keeps showing "Recommended update for libreoffice and xmlsec1" in an infinite way and then the run gets cancelled.

#6 Updated by GraceWang 2 months ago

  • Status changed from Blocked to Resolved

According to the latest comment from Dev for https://bugzilla.suse.com/show_bug.cgi?id=1187642
This issue can't be reproduced by Dev and from the latest 3 results in openQA this issue can't be reproduced either.

So, I am changing the status from BLOCKED to RESOLVED for now.

Please feel free to reopen or file a new ticket when this issue happens again in the future.

Also available in: Atom PDF