Project

General

Profile

action #94123

[sle][Migration][SLE15SP4] check needle issue which potential impact s390

Added by coolgw 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
-
Start date:
2021-06-17
Due date:
% Done:

0%

Estimated time:
20.00 h
Difficulty:

Description

Since a needle match logic has change, we need clone some test cases to verify whether needle still need update.

History

#1 Updated by coolgw 5 months ago

barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993225 _GROUP=0 --skip-download
Created job #6278702: sle-15-SP3-Migration-from-SLE12-SPx-s390x-Build187.1-offline_sles12sp3_ltss_pscc_asmm-lgm_all_full_lock@s390x-kvm-sle12 -> http://openqa.suse.de/t6278702
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993223 _GROUP=0 --skip-download
Created job #6278703: sle-15-SP3-Migration-from-SLE12-SPx-s390x-Build187.1-offline_sles12sp4_ltss_media_tcm-wsm-python2_def_full@s390x-kvm-sle12 -> http://openqa.suse.de/t6278703
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993220 _GROUP=0 --skip-download
Created job #6278704: sle-15-SP3-Migration-from-SLE12-SPx-s390x-Build187.1-offline_sles12sp5_media_base_full@s390x-kvm-sle12 -> http://openqa.suse.de/t6278704
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993217 _GROUP=0 --skip-download
Cloning dependencies of sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15_ltss_pscc_basesys-srv_all_minimal_zVM@s390x-zVM-Upgrade-m1
Created job #6278705: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15_ltss_pscc_basesys-srv_all_minimal_zVM_preparation@s390x-zVM-Upgrade-m1 -> http://openqa.suse.de/t6278705
Created job #6278706: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15_ltss_pscc_basesys-srv_all_minimal_zVM@s390x-zVM-Upgrade-m1 -> http://openqa.suse.de/t6278706
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993214 _GROUP=0 --skip-download
Created job #6278707: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp1_ltss_pscc_basesys-srv-lgm-pcm_all_full@s390x-kvm-sle15 -> http://openqa.suse.de/t6278707
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993212 _GROUP=0 --skip-download
Created job #6278708: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp2_media_basesys-srv-desk-dev_def_full@s390x-kvm-sle15 -> http://openqa.suse.de/t6278708
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5991173 _GROUP=0 --skip-download
Created job #6278709: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp2_pscc_base_all_minimal@s390x-kvm-sle15 -> http://openqa.suse.de/t6278709
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993229 _GROUP=0 --skip-download
Created job #6278710: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-online_sles15_pscc_basesys-srv-lgm-pcm_def_full_zypp@s390x-kvm-sle15 -> http://openqa.suse.de/t6278710
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5996561 _GROUP=0 --skip-download
Created job #6278711: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-online_sles15sp1_ltss_pscc_basesys-srv-phub_def_full_y@s390x-kvm-sle15 -> http://openqa.suse.de/t6278711

#2 Updated by coolgw 5 months ago

  • Estimated time changed from 4.00 h to 8.00 h

Enlarge effort since more needles need update.

#3 Updated by coolgw 5 months ago

Enlarge effort since more needles need update.

coolgw wrote:

barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993225 _GROUP=0 --skip-download
Created job #6278702: sle-15-SP3-Migration-from-SLE12-SPx-s390x-Build187.1-offline_sles12sp3_ltss_pscc_asmm-lgm_all_full_lock@s390x-kvm-sle12 -> http://openqa.suse.de/t6278702
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993223 _GROUP=0 --skip-download
Created job #6278703: sle-15-SP3-Migration-from-SLE12-SPx-s390x-Build187.1-offline_sles12sp4_ltss_media_tcm-wsm-python2_def_full@s390x-kvm-sle12 -> http://openqa.suse.de/t6278703
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993220 _GROUP=0 --skip-download
Created job #6278704: sle-15-SP3-Migration-from-SLE12-SPx-s390x-Build187.1-offline_sles12sp5_media_base_full@s390x-kvm-sle12 -> http://openqa.suse.de/t6278704

/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993220 _GROUP=0 --skip-download REPO_0=SLE-15-SP3-Full-s390x-GM-Media1
Created job #6285557: sle-15-SP3-Migration-from-SLE12-SPx-s390x-Build187.1-offline_sles12sp5_media_base_full@s390x-kvm-sle12 -> http://openqa.suse.de/t6285557

barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993217 _GROUP=0 --skip-download
Cloning dependencies of sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15_ltss_pscc_basesys-srv_all_minimal_zVM@s390x-zVM-Upgrade-m1
Created job #6278705: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15_ltss_pscc_basesys-srv_all_minimal_zVM_preparation@s390x-zVM-Upgrade-m1 -> http://openqa.suse.de/t6278705
Created job #6278706: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15_ltss_pscc_basesys-srv_all_minimal_zVM@s390x-zVM-Upgrade-m1 -> http://openqa.suse.de/t6278706
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993214 _GROUP=0 --skip-download
Created job #6278707: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp1_ltss_pscc_basesys-srv-lgm-pcm_all_full@s390x-kvm-sle15 -> http://openqa.suse.de/t6278707
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993212 _GROUP=0 --skip-download
Created job #6278708: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp2_media_basesys-srv-desk-dev_def_full@s390x-kvm-sle15 -> http://openqa.suse.de/t6278708
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5991173 _GROUP=0 --skip-download
Created job #6278709: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp2_pscc_base_all_minimal@s390x-kvm-sle15 -> http://openqa.suse.de/t6278709
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993229 _GROUP=0 --skip-download
Created job #6278710: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-online_sles15_pscc_basesys-srv-lgm-pcm_def_full_zypp@s390x-kvm-sle15 -> http://openqa.suse.de/t6278710
barry:~/:[0]#
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5996561 _GROUP=0 --skip-download
Created job #6278711: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-online_sles15sp1_ltss_pscc_basesys-srv-phub_def_full_y@s390x-kvm-sle15 -> http://openqa.suse.de/t6278711

#4 Updated by leli 5 months ago

  • Subject changed from [sle][Migration][SLE15SP3] check needle issue which potential impact s390 to [sle][Migration][SLE15SP4] check needle issue which potential impact s390

#5 Updated by coolgw 5 months ago

clone job on regression case since this should encounter more needle issue
barry:~/:[0]# 11sp4:
barry:~/:[127]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5991261 _GROUP=0 --skip-download
Created job #6299069: sle-15-SP3-Regression-on-Migration-from-SLE11-SP4-s390x-Build187.1-offline_sles11sp4_scc_all_full_zVM_preparation@s390x-zVM-Upgrade-m1 -> http://openqa.suse.de/t6299069
<=== SKIP 11sp4 action now since it should out of lifecycle.
barry:~/:[0]# 12p5
barry:~/:[127]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5991280 _GROUP=0 --skip-download WORKER_CLASS=s390-kvm-sle12Created job #6299070: sle-15-SP3-Regression-on-Migration-from-SLE12-SPx-s390x-Build187.1-offline_sles12sp5_pscc_sdk-asmm-contm-lgm-tcm-wsm_all_full@s390x-kvm-sle12 -> http://openqa.suse.de/t6299070
<=== new ticket submit poo#94390, other part are OK now
barry:~/:[0]# 15sp2
barry:~/:[127]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 6230192 _GROUP=0 --skip-download WORKER_CLASS=s390-kvm-sle12Created job #6299071: sle-15-SP3-Regression-on-Migration-from-SLE15-SPx-s390x-Build187.1-online_sles15sp2_pscc_basesys-srv-desk-dev-contm-lgm-py2-tsm-wsm_all_full@s390x-kvm-sle12 -> http://openqa.suse.de/t6299071
<=== needle related issue should gone , current blocked on the one exist issue, not needle

#6 Updated by coolgw 5 months ago

Rerun cases which on sle15(broken worker), replace to sle12
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993214 _GROUP=0 --skip-download WORKER_CLASS=s390-kvm-sle12
Created job #6305566: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp1_ltss_pscc_basesys-srv-lgm-pcm_all_full@s390x-kvm-sle15 -> http://openqa.suse.de/t6305566 <=======PASS
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993212 _GROUP=0 --skip-download WORKER_CLASS=s390-kvm-sle12
Created job #6305567: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp2_media_basesys-srv-desk-dev_def_full@s390x-kvm-sle15 -> http://openqa.suse.de/t6305567
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5991173 _GROUP=0 --skip-download WORKER_CLASS=s390-kvm-sle12
Created job #6305568: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp2_pscc_base_all_minimal@s390x-kvm-sle15 -> http://openqa.suse.de/t6305568 =======PASS
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993229 _GROUP=0 --skip-download WORKER_CLASS=s390-kvm-sle12
Created job #6305569: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-online_sles15_pscc_basesys-srv-lgm-pcm_def_full_zypp@s390x-kvm-sle15 -> http://openqa.suse.de/t6305569 =======PASS
barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5996561 _GROUP=0 --skip-download WORKER_CLASS=s390-kvm-sle12
Created job #6305570: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-online_sles15sp1_ltss_pscc_basesys-srv-phub_def_full_y@s390x-kvm-sle15 -> http://openqa.suse.de/t6305570 <=== this need new ticket?

https://progress.opensuse.org/issues/94219 is tracking this issue now.
barry:~/:[0]#

#7 Updated by coolgw 5 months ago

barry:~/:[0]# /usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5993212 _GROUP=0 --skip-download WORKER_CLASS=s390-kvm-sle12 REPO_0=SLE-15-SP3-Full-s390x-GM-Media1
Created job #6305987: sle-15-SP3-Migration-from-SLE15-SPx-s390x-Build187.1-offline_sles15sp2_media_basesys-srv-desk-dev_def_full@s390x-kvm-sle15 -> http://openqa.suse.de/t6305987 =====PASS

#8 Updated by coolgw 5 months ago

  • Status changed from New to Resolved
  • Estimated time changed from 8.00 h to 20.00 h

Close it, if any more issue happen then we can reopen it to continue tracking it.

Also available in: Atom PDF