Project

General

Profile

action #92945

[qe-core] reboot_and_install: unable to handle 15.x base image to reboot

Added by dimstar 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-05-21
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-external_iso@64bit_cirrus fails in
reboot_and_install

In order to be more realistic, a few tests have been changed to use a Leap 15.s base image instead of 42.x

Those tests first boot the base image, do some settings, then try to reboot the machine. But the test code is not ready to handle specialities of a 15.x base imahe

Test suite description

Maintainer: QE Core, jrauch@suse.de

Test installation using an ISO file on a second hard disk.

https://progress.opensuse.org/issues/19510
https://bugzilla.opensuse.org/show_bug.cgi?id=1040749

Reproducible

Fails since (at least) Build 20210520

Expected result

Last good: 20210519 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by favogt 2 months ago

In order to be more realistic, a few tests have been changed to use a Leap 15.s base image instead of 42.x

Is not quite correct. What happened is that previously openQA used tty7 for the x11 console if HDD_1 contains opensuse-42, but that broke upgrade tests because it was actually running Tumbleweed and needed tty2. This was changed and upgrade tests are working again: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12579

The affected tests use HDD_1=opensuse-42... and actually boot it, but now openQA uses tty7 because of VERSION=Tumbleweed.
Using a Leap 15.x HDD instead works around the tty issue because it uses the same tty as Tumbleweed, but it breaks further on because the code for triggering a reboot in GNOME tries the Tumbleweed sequence which fails on Leap.

Ideally all tests which mix different system versions properly update the VERSION variable throughout the run, like version_switch_origin_system/version_switch_upgrade_target.

#2 Updated by maritawerner 2 months ago

  • Subject changed from reboot_and_install: unable to handle 15.x base image to reboot to [qe-core] reboot_and_install: unable to handle 15.x base image to reboot

#3 Updated by favogt 2 months ago

Had a quick try with migration/version_switch_origin_system and migration/version_switch_upgrade_target.
It works mostly, but the reboot_and_install module triggers a reboot and then waits for inst-bootmenu still with the old version set, so the TW needle is not a candidate.
So this needed special code in reboot_and_install as well: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12611

#4 Updated by favogt 2 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

favogt wrote:

Had a quick try with migration/version_switch_origin_system and migration/version_switch_upgrade_target.
It works mostly, but the reboot_and_install module triggers a reboot and then waits for inst-bootmenu still with the old version set, so the TW needle is not a candidate.
So this needed special code in reboot_and_install as well: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12611

Got merged, closing. It should be possible to switch the tests to 15.x as well now.

Also available in: Atom PDF