Project

General

Profile

action #91350

[timeboxed:16h][sporadic] test fails in verify_undelete_snapshots

Added by syrianidou_sofia 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2021-04-19
Due date:
% Done:

0%

Estimated time:

Description

Observation

The module fails when the system is creating a new snapshot and it is expecting it to be marked as disposable. On successful runs, the number of the created snapshot is 18 and it is marked as disposable. When the number of the snapshot is 11, it's not marked as disposable. We need to figure out if this behavior is per design and adjust the module expectations or open a bug.

Blind guess, if it's on powerVM only, we should check if there is any test suite executed between image is created and this test suite. Therefore we should check that there are no extra snapshots in some runs and clean them up before the test execution to have the same setup in each run.

openQA test in scenario sle-15-SP3-Online-ppc64le-transactional_server_snapper@ppc64le-hmc-single-disk fails in
verify_undelete_snapshots

Test suite description

Test snapper features in a transactional update server

Reproducible

Fails since (at least) Build 95.1

Expected result

Last good: 174.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by syrianidou_sofia 5 months ago

  • Project changed from openQA Tests to qe-yast

#2 Updated by riafarov 5 months ago

  • Target version set to SLE 15 SP3

#3 Updated by riafarov 5 months ago

  • Subject changed from [sporadic] test fails in verify_undelete_snapshots to [timeboxed:16h][sporadic] test fails in verify_undelete_snapshots
  • Description updated (diff)
  • Status changed from New to Workable

#4 Updated by riafarov 5 months ago

  • Status changed from Workable to In Progress
  • Assignee set to riafarov

#5 Updated by riafarov 5 months ago

  • Status changed from In Progress to Feedback

#6 Updated by riafarov 5 months ago

  • Status changed from Feedback to Closed

#7 Updated by okurz 5 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: transactional_server_snapper@ppc64le-hmc-single-disk
https://openqa.suse.de/tests/5975051

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

Also available in: Atom PDF