Project

General

Profile

action #91326

[qem] Maintenance AZURE_LOGIN_WAIT_SECONDS is probably too low

Added by pdostal 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-04-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Error: Unable to list provider registration status, it is possible that this is due to invalid credentials or the service principal does not have permission to use the Resource Manager API, Azure error: azure.BearerAuthorizer#WithAuthorization: Failed to refresh the Token for request to https://management.azure.com/subscriptions/c011786b-59d7-4817-880c-7cd8a6ca4b19/providers?api-version=2016-02-01: StatusCode=401 -- Original Error: adal: Refresh request failed. Status Code = '401'. Response body: {"error":"invalid_client","error_description":"AADSTS7000215: Invalid client secret is provided.\r\nTrace ID: 5f8e0d88-3fda-46af-a68f-a41ecf434a00\r\nCorrelation ID: 6ad539e7-2f96-49a8-8bf3-1ebf21671110\r\nTimestamp: 2021-04-18 11:43:18Z","error_codes":[7000215],"timestamp":"2021-04-18 11:43:18Z","trace_id":"5f8e0d88-3fda-46af-a68f-a41ecf434a00","correlation_id":"6ad539e7-2f96-49a8-8bf3-1ebf21671110","error_uri":"https://login.microsoftonline.com/error?code=7000215"} Endpoint https://login.microsoftonline.com/a887795a-b916-4e1a-a350-78949c09bdb3/oauth2/token?api-version=1.0

on plan.tf line 1, in provider "azurerm":
1: provider "azurerm" {

s_R9m-1-

Observation

openQA test in scenario sle-12-SP5-AZURE-BYOS-Updates-x86_64-publiccloud_ltp_cve@az_Standard_A2_v2 fails in
run_ltp

Test suite description

Reproducible

Fails since (at least) Build 20210418-1 (current job)

Expected result

Last good: 20210417-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pdostal 3 months ago

Possible merge request.

#2 Updated by ph03nix 3 months ago

  • Subject changed from Maintenance AZURE_LOGIN_WAIT_SECONDS is probably too low to [qem] Maintenance AZURE_LOGIN_WAIT_SECONDS is probably too low

#3 Updated by pdostal 3 months ago

  • Status changed from New to In Progress
  • Assignee set to pdostal

#4 Updated by pdostal 3 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF