Project

General

Profile

action #90701

[VMware][hyperv] test fails in buildah_docker

Added by mloviska 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-04-06
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP3-JeOS-for-MS-HyperV-x86_64-jeos-container-engines_and_tools@svirt-hyperv-uefi fails in
buildah_docker

Test suite description

drhtC-0-
KThkT
from flask import Flask, render_template
import os, sys, ssl

app = Flask(__name__)
message = ""

@app.route("/")
def index():
    return render_template("index.html", message = message)

if __name__ == "__main__":
    ctx = ssl.create_default_context()
    ctx.check_hostname = False
    ctx.verify_mode = ssl.CERT_NONE

    if len(sys.argv) > 1:
        url = sys.argv[1]
    else:
        print("Program requires at least one argument!")
        sys.exit()

    cmd = "curl -I " + url
    response = os.system(cmd)
    if response == 0:
        message = "pass"
    else:
        message = "not pass"
    app.run(host="0.0.0.0", port=int(os.environ.get("PORT", 5000)))
SCRIPT_FINISHEDKThkT-0-

Seems like and TO issue overall the same command is used in more test cases and fails randomly.

Reproducible

Fails since (at least) Build 1.25 (current job)

Expected result

Last good: 24.50 (or more recent)

Further details

Always latest result in this scenario: latest

failure.jpg (210 KB) failure.jpg input failure mloviska, 2021-04-06 14:14
error_fdinfo_flags.jpg (198 KB) error_fdinfo_flags.jpg fdinfo mloviska, 2021-04-15 15:03
11174
11216

History

#1 Updated by mloviska 6 months ago

script_output's ctrl-d action sometimes logs out the current console.

#2 Updated by mloviska 6 months ago

Not sure what is the issue with this input

#3 Updated by mloviska 6 months ago

11174

#4 Updated by mloviska 6 months ago

Last issue/warning found that seems to be related to usage of record_info's in container tests.

[2021-04-09T10:48:47.777 CEST] [debug] <<< testapi::record_info(title="sle15-working-container", output=undef, result="ok")
Use of uninitialized value $_[0] in join or string at /usr/lib/perl5/vendor_perl/5.26.1/Mojo/File.pm line 141.

#5 Updated by mloviska 5 months ago

Snippet no.1

210         my $smoketest = qq[bash -c '/bin/uname -r; /bin/echo "Heartbeat from $image"; ps'];
219         script_run("set -x;ps; echo 'Hello I am a dog!'");
220         script_run("set -x;buildah run $container $smoketest");
# set -x;ps; echo 'Hello I am a dog!'; echo AtnLf-$?-
+ ps
  PID TTY          TIME CMD
 2049 hvc0     00:00:00 bash
 7982 hvc0     00:00:00 ps
+ echo 'Hello I am a dog!'
Hello I am a dog!
+ echo AtnLf-0-
AtnLf-0-
# set -x;buildah run sle15-working-container bash -c '/bin/uname -r; /bin/echo "Heartbeat from registry.suse.com/suse/sle15:15.3"; ps'; echo ELQ~f-$?-
+ set -x
+ buildah run sle15-working-container bash -c '/bin/uname -r; /bin/echo "Heartbeat from registry.suse.com/suse/sle15:15.3"; ps'
5.3.18-54-default
Heartbeat from registry.suse.com/suse/sle15:15.3
  PID TTY          TIME CMD
    1 pts/0    00:00:00 bash
    8 pts/0    00:00:00 ps
+ echo ELQ~f-0-
ELQ~f-0-

Snippet no.2

221         $smoketest = "/bin/uname -r; /bin/echo 'Heartbeat from $image'; ps";
222         script_run("set -x;ps; echo 'Hello I am a dog!'");
223         script_run("set -x;buildah run $container $smoketest");
# set -x;ps; echo 'Hello I am a dog!'; echo AtnLf-$?-
+ set -x
+ ps
  PID TTY          TIME CMD
 2049 hvc0     00:00:00 bash
 8055 hvc0     00:00:00 ps
+ echo 'Hello I am a dog!'
Hello I am a dog!
+ echo AtnLf-0-
AtnLf-0-
# set -x;buildah run sle15-working-container /bin/uname -r; /bin/echo 'Heartbeat from registry.suse.com/suse/sle15:15.3'; ps; echo LsI4D-$?-
+ set -x
+ buildah run sle15-working-container /bin/uname -r
5.3.18-54-default
+ /bin/echo 'Heartbeat from registry.suse.com/suse/sle15:15.3'
Heartbeat from registry.suse.com/suse/sle15:15.3
+ ps
  PID TTY          TIME CMD
 2049 hvc0     00:00:00 bash
 8112 hvc0     00:00:00 ps
+ echo LsI4D-0-
LsI4D-0-

Also available in: Atom PDF