Project

General

Profile

action #90320

[sle][migration][sle15sp3] Run verify log for PR https://github.com/os-autoinst/os-autoinst/pull/1633

Added by leli 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-03-19
Due date:
% Done:

100%

Estimated time:
20.00 h
Difficulty:

Description

We need try to verify this PR related needle, find a regression job with all modules to check it.

History

#1 Updated by leli 4 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

A verify for regression test. http://10.161.8.165/tests/9#live

#2 Updated by leli 4 months ago

  • % Done changed from 20 to 30

Verification log for SLED test. http://10.161.8.165/tests/10#live

#3 Updated by leli 4 months ago

Add comments to the PR:

For migration test, I have run two jobs to verify this:

Regression test with all modules and extensions: http://10.161.8.165/tests/10#step/boot_to_desktop/49
SLED migration test: http://10.161.8.165/tests/9#step/boot_to_desktop/45

Both failed very early, for tag ' inst-bootmenu-boot-harddisk'. It means almost all migration test will be blocked here.

#4 Updated by coolgw 4 months ago

  • Estimated time set to 12.00 h

#5 Updated by coolgw 4 months ago

  • Estimated time changed from 12.00 h to 20.00 h

#6 Updated by leli 4 months ago

  • % Done changed from 30 to 60

#7 Updated by leli 4 months ago

Update comments in https://github.com/os-autoinst/os-autoinst/pull/1633 also.

#Oliver:
@lemon-suse and the idea is that after creating the needles locally you can provide a pull request to have these needles in the main repos before we deploy the changes from this PR into production
Also my idea is that os-autoinst/openQA#3804 can help to ease testing of this and other os-autoinst versions in the future

Sure, I'm working on this on my local environment, I will file a MR when finished and please help to review and merge. Thanks.

Hi Oliver and Coolo, please help to review and merge the MR https://gitlab.suse.de/openqa/os-autoinst-needles-sles/-/merge_requests/1525 .
There 20 needles included in the MR but shouldn't include all needles affected by the PR since only have three x86 jobs tested on local environment. I think there will be some needles need to re-needle after this PR merged for the different of ARCH and more test coverage, that is expected. So would you merge the PR during RC phase? The concern is still the workload for needles. How about to do this after RC phase?

#8 Updated by leli 3 months ago

  • Status changed from In Progress to Feedback

#9 Updated by leli about 2 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 60 to 100

PR merged and MR merged. So close this ticket.

Also available in: Atom PDF